Announcement

Collapse
No announcement yet.

Notifications (Postifx installé) [Résolu]

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Notifications (Postifx installé) [Résolu]

    Bonjour à tous,

    Voici ma config:
    Debian, nagios 2.5, oreon 1.3.2, postfix

    Oreon et nagios fonctionnent correctement, mais je ne recois pas de notifications.

    Je vois dans /var/log/mail.log des essais de mail qui sont rejetés par mon relayeur pour la cause :

    Jan 23 11:16:55 infonux postfix/smtp[11793]: CB348A913D: to=<[email protected]>, relay=mailhost.u-strasbg.fr[130.79.200.153], delay=61578, status=deferred (host mailhost.u-strasbg.fr[130.79.200.153] said: 451 4.0.0 Sender address must resolve (see http://www.kit-jussieu.org/rejet/) (in reply to MAIL FROM command))

    parcontre si je tape mail -s "sujet" [email protected] je recois bien ce courrier.
    Je vois que les mails envoyés par nagios se font depuis [email protected]domain alors que le fichier /etc/maildomain contient bien mondomain.fr (ce qui est utilisé lorsque je tape la commande en console).

    Est-ce qu'il y a une configuration spécifique a faire dans nagios à cause de postfix ? Je suis obligé d'avoir postfix sur cette machine pour d'autres raisons.

    J'ai bien compris que mon relayeur empeche nagios d'envoyer les notifications parce que l'adresse d'expéditeur n'est pas connu (@localhost.localdomain). Comment faire pour qu'il utilise @mondomain.fr.

    J'ai essayer en utilisant /usr/sbin/sendmail -f [email protected] dans la config de nagios (via oreon) mais ca ne marche pas mieux.

    Un autre test qui confirme mon problème. La commande suivante fonctionne depuis la console:

    /usr/bin/printf "%b" "message d'alerte" | /usr/bin/mail -s "sujet de l'alerte" [email protected] mais pas depuis nagios.

    Auriez vous une géniale idée à me soumettre ?

    Merci d'avance et bravo pour le travail effectué.

  • #2
    Re: Notifications (Postifx installé)

    Originally posted by ceoph
    Un autre test qui confirme mon problème. La commande suivante fonctionne depuis la console:

    /usr/bin/printf "%b" "message d'alerte" | /usr/bin/mail -s "sujet de l'alerte" [email protected] mais pas depuis nagios.
    Si cette commande marche en ligne de commande, et que c'est la meme que tu utilises dans ta configuration des commandes Nagios, elle doit marcher car Nagios execute la meme chose (en remplacant les macros).

    L'email de ton contact est bien "[email protected]" et tu n'as PAS coché l'option "n" dans les parametres de notif ?
    Romain Le Merlus
    Centreon Forge
    MERETHIS

    Comment


    • #3
      tu peux aussi configurer to domaine dans le fichier de conf de postfix /etc/postfix/main.cf

      Code:
      smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU) 
      myhostname =    
      mydomain =       
      myorigin = $mydomain 
      mydestination = $myhostname, localhost, $myhostname.$mydomain, localhost.$mydomain 
      relayhost =       
      mynetworks = 127.0.0.0/8 
      inet_interfaces = all 
      
      Renseigner les valeurs vides par: 
      
      myhostname = <Nom Machine>         Ex: localhost 
      mydomain = <Domaine de messagerie>       Ex : Mydomain.com 
      relayhost = <Serveur de messagerie avec les crochets>    Ex: [smtp.mydomain.fr]

      sinon c'est une typo et tu as tapé quelquepart locadomain au lieu de localdomain
      Je vois que les mails envoyés par nagios se font depuis [email protected]domain

      Comment


      • #4
        Notifications (Postifx installé)

        Bonjour,

        Merci pour les propositions mais ca n'a rien changé.

        Voici mon main.cf de Postfix

        myhostname = infonux.exploitation.local
        mydomain = mondomain.fr
        alias_maps = hash:/etc/aliases
        alias_database = hash:/etc/aliases
        myorigin = /etc/mailname
        mydestination = exploitation.local, localhost.localdomain, localhost.localdomain, localhost
        relay_domains = $mydestination
        relayhost = [mailhost.u-strasbg.fr]
        mailbox_command = procmail -a "$EXTENSION"
        mailbox_size_limit = 0
        recipient_delimiter = +
        mynetworks_style = host
        inet_interfaces = all
        local_recipient_maps =
        #smtpd_recipient_restrictions =
        smtpd_sender_restrictions =

        et /etc/mailname contient bien mondomain.fr

        Nagios prend toujours [email protected]ldomain au lieu de [email protected] !!!

        Est ce que quelqu'un a déjà eu ce problème ?? Est ce mon fichier de conf postfix qui est erroné ??

        Merci d'avance

        Comment


        • #5
          ça pourrait venir de la ligne mydestination

          mydestination = exploitation.local, localhost.localdomain, localhost.localdomain, localhost

          essaye de rajouter $myhostname.$mydomain à la fin

          Code:
          mydestination = exploitation.local, localhost.localdomain, localhost.localdomain, localhost, $myhostname.$mydomain
          + redemarrer postfix

          Comment


          • #6
            Je suis un boulet

            Je suis un gros boulet.

            Dans la conf de mon utilisateur, en voulant avoir toutes les notifications j'ai coché none.

            Je pensais que ce paramètre était dans la conf du service.

            Milles excuses.

            Comment


            • #7
              Re: Notifications (Postifx installé)

              Originally posted by ceoph
              Merci pour les propositions mais ca n'a rien changé.
              En meme temps si on te donne des solutions et que tu ne les testes pas... cf mon post... :roll:
              Romain Le Merlus
              Centreon Forge
              MERETHIS

              Comment

              Working...
              X