Announcement

Collapse
No announcement yet.

Javascript Errors

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Javascript Errors

    Hi,

    I just installed Oreon 1.3.2 on my CentOS 4.4 (RHEL 4 based) server with nagios 2.6. Installation was succesfull, and now I want to add some contacts, hosts, services and so on.

    But when I try to add a contact to a contactgroup, or a host to a contactgroup or anything at all with the add and remove buttons next to it, I get a javascript error.

    For example: When trying to add a user to a contactgroup the following error is displayed:
    Line: 222
    Char: 1
    Error: Object expected
    Code: 0
    URL: http://hostname/oreon/oreon.php?p=603&o=c&cg_id=1

    I'm using IE7, but on another PC with IE6 the same error appears. Also I tried oreon version 1.3.3. It gave the same kind of error messages.

    Am I doing something wrong? Has anybody else encounterd this problem before?

    Thanx, Floris Jan

  • #2
    I have this too

    Hi there.

    I have the same type of errors on oreon 1.3.3.

    As far as i know it was a bug introduced between 1.3.1 and 1.3.3.

    When i ran 1.3.3 these errors was not there, i have reported this problem on the bug page here: http://bugs.oreon-project.org/?do=de...296#comment399

    I would like you to make a comment on that if possible, and describe the errors you see. Since im not sure how i document the errors. So if you coudl create a flyspray account (the system the oreon developers use to track bugs) that would help.

    By the way, i dont have the problem if i use IE 6 as browser.

    Best regards

    Jonas Larsen

    Comment


    • #3
      I don't think the error I have is the same as yours, Jonas. I only get an error (as far as I know) when I want to link a contact to a contact group or any other function that uses the same control (the add/delete buttons).

      I tried and have the error in IE6 ad well. With firefox 2.0 I don't get the javascript error, but when clicking the Add button, nothing happens.

      I hope someone has a solution for my problem or can point me in a direction to look for the cause of it.

      Thanks, Floris Jan.

      Comment


      • #4
        Problem Sovled!!

        I found a thread in the French forum (see http://forum.oreon-project.org/showthread.php?t=2634) with the same problem and a solution as well.
        The solution included an upgrade of PHP to version 5 and PEAR.

        Thanx anyway!

        Comment

        Working...
        X