Announcement

Collapse
No announcement yet.

Installation sur Ubuntu5

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Installation sur Ubuntu5

    En préalable , merci pour ce beau boulot à l'équipe d'oreon...

    Quelques petits soucis cependant, j'ai pas mal galéré sur apache (script d'init ubuntu à modifier a priori)

    Tout fonctionne sur Oreon en v1.0 sauf la notification par mail, et le redémarrage du daemon nagios.

    (la génération fonctionne mais pas le rédémarrage bizare)

    J'ai patché en v1.1 et je suis revenu en arrière car problème avec les plugins 'a priori $user$' ??? si vous avez des choses la dessus...


    Merci d'avance

  • #2
    Merci bcp

    il faut simplement creer les variable dans options : $users1$=/usr/local/nagios/libexec et ca devrait fonctionner sans pb..

    bon courage
    Julien Mathis
    Centreon Project Leader
    www.merethis.com |

    Comment


    • #3
      Ubuntu

      Merci pour la réponse super rapide,

      Je passe l'upgrade en V1.1, parcontre j'ai toujours mon problème de redémarrage de nagios et de l'envoie de mail (rien dans tail -f /var/log/mail.log), dans la partie configuration , la génération s'effectue correctement avec la sortie de nagios.

      L'installation de nagios est réalisé avec le kit d'installation, j'ai modifié légérement le script de lancement de nagios qui renvoyé une erreur avec l'option -l de su (j'ai remplacé par "su -" )


      Merci de votre aide

      Comment


      • #4
        si ca redemarre pas c que le sudo est pas bien configuré... nous on configure une commande /etc/init.d/nagios restart...

        regarde si c bien cette commande pour ta distrib
        Julien Mathis
        Centreon Project Leader
        www.merethis.com |

        Comment


        • #5
          ubuntu

          Merci

          Pour sudo

          il faut simplement modifier la ligne dans /etc/sudoers

          User_Alias OREON=apache

          par

          User_Alias OREON=www-data

          www-data est l'utilisateur par défaut pour apache

          J'ai encore un dernière problème de notification par mail,

          le chemin par défaut du mailler est /usr/bin/mail sur ubuntu, j'ai donc

          modifier le paramétrage en conséquence, mais cela ne marche pas

          d'envoie malgrès la notification activé.

          A suivre donc

          Comment

          Working...
          X