Announcement

Collapse
No announcement yet.

pb PEAR et ldap.so

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • pb PEAR et ldap.so

    apres l'installation voici mon pb ds l(interface web pour parametrage
    Warning: PHP Pear not found
    /usr/share/pear/PEAR.php (ce fichier se trouve ds /usr/share/php/PEAR.php.

    puis

    Warning: ldap.so not loaded in php.ini alors que ds php.ini de /etc/php4/apache/php.ini c'est bien mis .

    quelqu'un a une idée.

  • #2
    Originally posted by sylvain View Post
    apres l'installation voici mon pb ds l(interface web pour parametrage
    Warning: PHP Pear not found
    /usr/share/pear/PEAR.php (ce fichier se trouve ds /usr/share/php/PEAR.php.
    # aptitude install php4-pear

    Originally posted by sylvain View Post
    Warning: ldap.so not loaded in php.ini alors que ds php.ini de /etc/php4/apache/php.ini c'est bien mis .
    # aptitude install php4-ldap

    Je suppose que tu as une Debian, faute de précisions.
    Toutefois, tu risques ensuite d'avoir des problèmes pour installer les autres modules PEAR via apt. Il faudra soit passer par la commande "pear install" ou créer les paquets manquants (il existe une commande nommée dh-make-php qui permet de créer des squelettes de paquets debian source à partir d'archives de modules PEAR et PECL (à l'image de la commande dh-make-perl pour les modules CPAN de Perl).
    Raphaël 'SurcouF' Bordet
    Je ne teste pas mes plugins en root, tu ne testes pas tes plugins en root...
    Dons Paypal

    Comment


    • #3
      merci

      merci je regarde

      Comment


      • #4
        que prendre comme distribution alors ?

        que prendre comme distribution alors ?
        avant j'avais une debian pour l"ancienne version de oreon et nagios 1.2 ?

        Comment


        • #5
          Originally posted by sylvain View Post
          que prendre comme distribution alors ?
          avant j'avais une debian pour l"ancienne version de oreon et nagios 1.2 ?
          Debian est une trés bonne distribution. Simplement, tu ne trouveras pas la plupart des modules PEAR requis par les dernières versions d'Oreon avec la version stable (sarge).
          Raphaël 'SurcouF' Bordet
          Je ne teste pas mes plugins en root, tu ne testes pas tes plugins en root...
          Dons Paypal

          Comment


          • #6
            De mon coté j'ai installé Nagios+Oreon sur une Mandrake 10.0 et j'ai pas mal galéré, notamment avec php-pear..
            Une page sur l'installation de php-pear qui explique très bien comment faire :
            http://pear.php.net/manual/fr/installation.php

            En résumé pour l'installer :
            # links -source http://go-pear.org/ | php
            Suivre les instructions :
            ENTER
            ENTER
            ENTER
            Y (yes)
            Downloading package...
            Il demande de modifier php.ini : y (yes)
            ENTER

            Après pour installer les extentions :
            # pear install -o -f --alldeps [nom_extention1] [nom_extention2] [etc...]
            Il devrait directement les prendre depuis le site go-pear.org, donc tu auras les dernières versions (certaines n'existe pas encore en stable mais c'est normal).

            A la page d'Oreon "5. Verifying PHP Pear Component :" tout doit être OK. Si ce n'est pas le cas, en bas de la page tu as la commande à rentrer pour que tout soit ok.

            En espérant que ça t'aide.
            Debian Etch 4.0
            Nagios v2.9 - Oreon v1.4-5 - Nagios Status Map 1.1 - Nagios Checker 0.9.5
            Niveau Linux : ~débutant

            Comment


            • #7
              est ce qu'il faut ajouté une ligne dans le fihier php.ini.? car j'installé un egroupware chez moi j'ai xampp sous fédora core 6 j'ai suivi la procédure ca s'installe mais quand je lance le teste pour voir il me répond cheking pear = false.
              je me suis demandé s'il fallait ajouté une ligne dans le php.ini

              Comment

              Working...
              X