Announcement

Collapse
No announcement yet.

modules pear et compilation php4

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • modules pear et compilation php4

    Bonjour à tous,

    Désolé par avance car il me semble que la question dépasse un peu le stade de la simple installation d'oreon.

    Il s'agit pour moi d'installer nagios et oreon sur un serveur sous Debian Sarge (3.1), et pour répondre à certaines contraintes, je dois effectuer une compilation manuelle d'apache2, mysql 5 et php4.

    Pour la configuration de php4 avant compilation, je passe cette ligne d'arguments :
    ./configure --with-apxs2=/usr/local/apache2/bin/apxs --with-mysql=/usr/local/mysql/ --enable-track-vars --enable-sockets --with-config-file-path=/etc/httpd --enable-ftp --with-zlib --with-pear --with-openssl=/usr/local/ssl --enable-exif --with-gd --disable-debug --disable-rpath --disable-static --with-pic --with-layout=GNU --enable-calendar --enable-sysvsem --enable-sysvshm --enable-sysvmsg --enable-trans-sid --enable-bcmath --with-bz2 --enable-ctype --with-snmp --with-iconv --enable-filepro --with-gettext --enable-mbstring --enable-shmop --enable-wddx --with-xmlrpc --enable-yp --with-zlib --without-pgsql --enable-dbx --without-mm --enable-gd-native-ttf --with-imap-ssl --enable-soap --enable-dbase --prefix=/usr/local/PHP --enable-xml

    La compilation s'effectue correctement, mais là où ça se corse c'est à l'installation des modules Pear. Sans mentir, cela fait plus d'une semaine que je m'arrache les cheveux sur cette histoire.
    J'ai essayé plusieurs méthodes : installer pear-1.3.5, tenter une mise à jour derrière, j'ai exporté dans le config-set les paramètres propres à mon environnement et compagnie, mais je me heurte sans arrêt au même problème : Il me manque toujours des modules pear, avec comme sortie d'erreur :
    No handlers for package.xml version 2.0

    Alors je sais qu'il s'agit d'un problème de version et qu'il faut passer à PEAR 1.5 mais cela arrive entre autres quand je tente cette mise à jour :mad: Comprenez ma détresse

    Je me dis que ceux qui passent par apt pour installer apache, php et mysql ne rencontrent pas ce genre de probleme, le truc doit donc se trouver lors de ma compilation, mais vu que je bute sur ce probleme depuis un bail, je crois que je n'ai pas assez de recul...

    Bref si vous avez une petite idée je suis preneur; merci d'avance à tous

  • #2
    Je ne sais pas si je répond à la question, mais il me semble que :
    "No handlers for package.xml version 2.0"
    signifie que tu n'as pas le package php-xml
    Debian Etch 4.0
    Nagios v2.9 - Oreon v1.4-5 - Nagios Status Map 1.1 - Nagios Checker 0.9.5
    Niveau Linux : ~débutant

    Comment

    Working...
    X