Announcement

Collapse
No announcement yet.

[Probleme Perfparse] Help me

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Probleme Perfparse] Help me

    Bonjour tous le monde. J'installais tranquillement Nagios et Oreon. Jusqu'a la pas de probleme. Mais j'ai eu un probleme avec Perfparse. Je fais un ./configure et ca me fait les erreurs marqué si dessous. Une idée?

    checking build system type... i686-pc-linux-gnu
    checking host system type... i686-pc-linux-gnu
    checking target system type... i686-pc-linux-gnu
    checking for a BSD-compatible install... /usr/bin/install -c
    checking whether build environment is sane... yes
    checking for gawk... no
    checking for mawk... mawk
    checking whether make sets $(MAKE)... yes
    checking for g++... no
    checking for c++... no
    checking for gpp... no
    checking for aCC... no
    checking for CC... no
    checking for cxx... no
    checking for cc++... no
    checking for cl... no
    checking for FCC... no
    checking for KCC... no
    checking for RCC... no
    checking for xlC_r... no
    checking for xlC... no
    checking for C++ compiler default output file name... configure: error: C++ compiler cannot create executables
    See `config.log' for more details.


    Je suis sous debian 3.1 avec oreon 1.3.3 , nagios 2.5 et perfparse 106.1
    Last edited by Zelgadis36; 12 March 2007, 14:01.

  • #2
    apt-get install g++ make

    Comment


    • #3
      merci

      j'avais installer g++ mais pas make... quel buse...

      Comment


      • #4
        juste une chose : ( a la fin de mon ./configure)
        ************************************************** ***

        WARNING WARNING WARNING WARNING WARNING WARNING WARNING
        Perfparse CGI is now perfparse.cgi.
        If you have upgrading, the development team suggests
        that you remove your old perfgraph.cgi to avoid
        any confusion.

        ************************************************** ***

        WARNING WARNING WARNING WARNING WARNING WARNING WARNING
        Be sure to install libpp_storage_*.so files in a directory
        that ld.so knows (/etc/ld.so.conf, run ldconfig if needed,
        or $LD_LIBRARY_PATH)


        ************************************************** ***
        c normal ou j'ai quelque chose de bizarre?

        Comment


        • #5
          Olala le bad.......

          Non c'est normal, (ce sont que des warning hein), le deuxieme message est cependant à bien prendre en compte

          Comment


          • #6
            aie

            Au secours !

            j'ai fait mon ./configure et mis a part les warnings aucun probleme

            Puis je fait make et j'ai de nombreux messages de ce type qui apparaisse:
            mais a la fin j'ai pas de messages d'erreurs
            config_file.c:144: warning: null argument where non-null required (argument 2)
            config_file.c:144: warning: null argument where non-null required (argument 2)

            config_file.c:146: warning: null argument where non-null required (argument 2)


            Et ensuite je fait make install et la rien ne va plus, il me met ca :
            make[1]: Entering directory `/mnt/perfparse-0.105.6/contrib'
            make[2]: Entering directory `/mnt/perfparse-0.105.6/contrib'
            make[2]: Nothing to be done for `install-exec-am'.
            make[2]: Nothing to be done for `install-data-am'.
            make[2]: Leaving directory `/mnt/perfparse-0.105.6/contrib'
            make[1]: Leaving directory `/mnt/perfparse-0.105.6/contrib'
            Making install in po
            make[1]: Entering directory `/mnt/perfparse-0.105.6/po'
            /bin/sh .././mkinstalldirs /usr/local/share
            installing fr.gmo as /usr/local/share/locale/fr/LC_MESSAGES/perfparse.mo
            installing de.gmo as /usr/local/share/locale/de/LC_MESSAGES/perfparse.mo
            if test "perfparse" = "gettext-tools"; then \
            /bin/sh .././mkinstalldirs /usr/local/share/gettext/po; \
            for file in Makefile.in.in remove-potcdate.sin quot.sed boldquot.sed [email protected]er [email protected]er insert-header.sin Rules-quot Makevars.template; do \
            /usr/bin/install -c -m 644 ./$file \
            /usr/local/share/gettext/po/$file; \
            done; \
            for file in Makevars; do \
            rm -f /usr/local/share/gettext/po/$file; \
            done; \
            else \
            : ; \
            fi
            make[1]: Leaving directory `/mnt/perfparse-0.105.6/po'
            Making install in scripts
            make[1]: Entering directory `/mnt/perfparse-0.105.6/scripts'
            make[2]: Entering directory `/mnt/perfparse-0.105.6/scripts'
            test -z "/usr/local/bin" || mkdir -p -- "/usr/local/bin"
            /usr/bin/install -c 'perfparse.sh.example' '/usr/local/bin/perfparse.sh.example'
            make[2]: Nothing to be done for `install-data-am'.
            make[2]: Leaving directory `/mnt/perfparse-0.105.6/scripts'
            make[1]: Leaving directory `/mnt/perfparse-0.105.6/scripts'
            make[1]: Entering directory `/mnt/perfparse-0.105.6'
            make[2]: Entering directory `/mnt/perfparse-0.105.6'
            make[2]: Nothing to be done for `install-exec-am'.
            make[2]: Nothing to be done for `install-data-am'.
            make[2]: Leaving directory `/mnt/perfparse-0.105.6'
            make[1]: Leaving directory `/mnt/perfparse-0.105.6'

            Je suis coulé , quelqu'un a une idée. Perfparse c pas facile a installer...

            Comment


            • #7
              M'sieur

              As tu installé ces packages avant de compiler perfparse

              apt-get install libglib2.0-dev libglib2.0-data libmysqlclient14-dev


              Je te conseille par ailleurs un ./configure suivi des options suivantes :

              configure -prefix=/usr/local/nagios -with-imagedir=/usr/local/nagios/share/images -with-cgidir=/usr/local/nagios/sbin -with-http_image_path=/nagios/images -with-gdlib_config_dir=/usr/lib

              Si bien sur Nagios est installé dans /usr/local/nagios

              Comment


              • #8
                arf

                Deja merci Maestro ( tu porte bien ton pseudo )
                alors j'ai fait comme tu m'as dit
                apt-get install libglib2.0-dev libglib2.0-data libmysqlclient14-dev
                et ./configure -prefix=/usr/local/nagios -with-imagedir=/usr/local/nagios/share/images -with-cgidir=/usr/local/nagios/sbin -with-http_image_path=/nagios/images -with-gdlib_config_dir=/usr/lib

                et ca marche pas plus.... snif

                Comment


                • #9
                  Alors execute les commandes suivantes car selon moi le 'make install' semble nickel

                  # make clean

                  # configure -prefix=/usr/local/nagios -with-imagedir=/usr/local/nagios/share/images -with-cgidir=/usr/local/nagios/sbin -with-http_image_path=/nagios/images -with-gdlib_config_dir=/usr/lib

                  # make

                  # make install

                  # echo $?


                  Si le résultat de la derniere commande est 0, alors c'est gagné


                  EDIT :
                  make[1]: Entering directory `/mnt/perfparse-0.105.6/contrib'
                  Utilise aussi perfparse version 106.1

                  Comment


                  • #10
                    smack

                    grand maitre jedi ^^. le resultat est 0.

                    apres il faut que je créais une base avec mysql c j'ai bien compris?
                    je fais donc mysql -U root
                    et le seul résultat que j'obtiens c ca:
                    ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
                    j'ai bien un mot de passe avec mysql-server mais il me le demande pas , donc je pense pas que ca vienne de ca.

                    Alors Maitre maestro (ca fait une répetition) ou un autre auriez vous une idée? le boulet que je n'y arrive pas....

                    Comment


                    • #11
                      Si ton password mysql est deja configuré, la syntaxe correcte est la suivante

                      # mysql -u root -p

                      mysql --help pour plus d'infos

                      Comment


                      • #12
                        deja mille merci pour ton aide et ta patience.
                        Mais je suis tjs incapable de faire quelque chose tous seul. snif.

                        j'essaye de créer ma base.
                        je tape
                        mysql> create perfparse;
                        et ca me fais ca:
                        ERROR 1064 (42000): You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'perfparse' at line 1
                        pourtant ; c bien dans la norme sql?! j'ai regarder l'aide mysql en faisant man mysql et mysql --help ca ne m'a pas aider . Ou alors je n'ai pas eté capable de voir la solution.

                        et encore merci pour ton aide

                        Comment


                        • #13
                          http://www.google.fr/search?q=mysql+create&start=0

                          Comment


                          • #14
                            Originally posted by Zelgadis36 View Post
                            deja mille merci pour ton aide et ta patience.
                            Mais je suis tjs incapable de faire quelque chose tous seul. snif.

                            j'essaye de créer ma base.
                            je tape
                            mysql> create perfparse;
                            et ca me fais ca:
                            ERROR 1064 (42000): You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'perfparse' at line 1
                            pourtant ; c bien dans la norme sql?! j'ai regarder l'aide mysql en faisant man mysql et mysql --help ca ne m'a pas aider . Ou alors je n'ai pas eté capable de voir la solution.

                            et encore merci pour ton aide
                            C'est CREATE DATABASE PERFPARSE.

                            Voici les commandes que j'ai tapé :

                            mysql -u root -p
                            create database perfparse;
                            use perfparse;
                            source /tmp/perfparse-0.106.1/scripts/mysql_create.sql

                            J'ai source qui pointe vers /tmp car j'ai dézippé PERFPARSE dans le TMP

                            Comment


                            • #15
                              merci

                              j'avais trouvé la bonne syntaxe mais merci kan meme.C sympa

                              Comment

                              Working...
                              X