Announcement

Collapse
No announcement yet.

10. Oreon Configuration File : Critical: Not Writeable file [ubuntu]

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 10. Oreon Configuration File : Critical: Not Writeable file [ubuntu]

    Bonjour à tous,

    Lors de l'installation de Oreon sur Ubuntu, j'ai un problème à la phase 10.

    Component Status
    Writable Oreon Configuration File (oreon.conf.php) Critical: Not Writeable
    root:root (0)
    Should be : (775)
    Generate configuration file OK

    ca semble être un problème de droit d'ecriture mais je ne sais pas le résoudre même après plusieurs recherche sur les forums.

    Sans être sûr, voici le répertoire qui poserait problème :

    /usr/local/oreon/www# ls -lts
    total 112
    4 drwxrwxrwx 6 www-data www-data 4096 2007-03-20 17:55 install

    A des fins de débug, j'ai moi même positionné les droits 777 sur le répertoire ci dessus mais sans succès.

    J'ai lu d'éventuels problèmes possible avec SELinux ? comment puis-je le désactiver simplement ?

    Que puis vérifier pour m'assurer que apache à bien les droits lors du parametrage ?

    SeLinux semble ne pas être installé à l'exception du paquet "libselinux1", j'ignore si il l'était par default.

    Merci d'avance pour votre aide car là je seche.

    BZH

  • #2
    les droits sur www ?
    Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
    Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
    Fedora Core 5 - 2.6.20-1.2320

    Comment


    • #3
      hello,

      vérifies que tu as bien php-posix.
      StatusMap Module - NDO Tools Module - ImportCSV Module - SNMP-UI Module - PDFReports Module
      Dons Paypal

      Comment


      • #4
        Vérifies le niveau de sécurité de selinux si il est fixé à enforcing dans /etc/selinux/config il bloque la création de oreon.conf.php modifie le fichier et passe sur permissive. Tu baisses ta sécurité !! ou dans l'interface graphique de gestion de selinux règle la sécurité de http.

        Comment


        • #5
          découverte automatique [oreon 1.3.3 sous ubuntu]

          Merci à tous pour vos orientations,

          j'ai procédé à un repassage de script et c'est passé, ...un problème de droit probablement.

          Par contre j'ai installé la dernière version 1.3.3 depuis le site.
          Les options d'oreon m'informe d'une version 1.3.2, serait-ce un bug ?

          Je viens de mettre en fonctionnement l'interface et je souhaiterais faire une DECOUVERTE AUTOMATIQUE de mes équipements. Pouvez-vous m'orienter ? je ne trouve pas l'option "nmap" pourtant installée avec apt-get en prérequis.

          Merci

          BZH

          Comment


          • #6
            bonjour à tous,

            je suis en train d'installer oreon et j'ai exactement le même problème pour l'étape 10.

            selinux est provisoirement "disabled",
            dans httpd/conf.d/oreon.conf, j'ai mis : AllowOverride All (provisoirement)
            les droits d'acces aux fichiers de conf sont par défaut 775,

            j'installe une version 1.3.3 et j'ai un nagios 2.7 qui tourne.

            qu'entendez vous pas un "repassage de script" ?? pour que ca fonctionne ?

            le problème peut-il venir du fait que j'installe oreon sur un serveur distant ?

            cordialement
            Gaé

            Comment


            • #7
              Originally posted by gae View Post
              bonjour à tous,

              je suis en train d'installer oreon et j'ai exactement le même problème pour l'étape 10.

              selinux est provisoirement "disabled",
              dans httpd/conf.d/oreon.conf, j'ai mis : AllowOverride All (provisoirement)
              les droits d'acces aux fichiers de conf sont par défaut 775,

              j'installe une version 1.3.3 et j'ai un nagios 2.7 qui tourne.

              qu'entendez vous pas un "repassage de script" ?? pour que ca fonctionne ?

              le problème peut-il venir du fait que j'installe oreon sur un serveur distant ?

              cordialement
              Gaé
              bon, j'ai trouvé, ca venait de ma conf httpd, ca a fonctionné avec le config suivante :
              AddType application/x-java-jnlp-file .jnlp
              Alias /oreon/ /usr/local/oreon/www/
              <Directory "/usr/local/oreon/www">
              Options None
              # AllowOverride All
              # AllowOverride AuthConfig Options
              Order deny,allow
              Deny from all
              Allow from (l'adresse de la patte du proxy pour joindre le lan sur lequelle tourne mon navigateur)
              Allow from 127.0.0.1
              </Directory>

              Comment


              • #8
                oups !

                Désolé, je viens de lire ton message que maintenant.
                good luck !
                bzh

                Comment

                Working...
                X