Announcement

Collapse
No announcement yet.

Pbme pour générer les fichiers Nagios

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Arkhan
    replied
    Originally posted by Lemmy78 View Post
    Plus les erreurs suivantes sur la page de config des hosts :

    Warning: opendir(/usr/local/nagios/share/images/logo/) [function.opendir]: failed to open dir: No such file or directory in /usr/local/oreon/www/include/common/common-Func.php on line 903
    J'ai la même erreur, ca vient du chemin "/usr/local/nagios/share/images/logo/" qui n'existe effectivement pas. Le bon est "/usr/local/nagios/share/images/logos/"

    Par contre, je ne sais pas où ça se corrige :mrgreen:
    Je suis allé voir dans common-Func.php et ça doit être le "nagios_path_img" qui est mauvais... si tu vois où ça se corrige ça m'intéresse, car je n'ai pas encore trouvé..

    Edit : je n'avais pas vue la 2e page -_- du coup ma réponse ne sert pas à grand chosen dslé !
    Last edited by Arkhan; 20 April 2007, 12:36.

    Leave a comment:


  • WAtt
    replied
    Salut,

    Essai de mettre un "\" avant le @.

    C'est hélas assez chiant les caractères spéciaux


    WAtt

    Leave a comment:


  • Lemmy78
    replied
    Salut,

    Nagios tourne (d'ailleurs le monitoring des hosts est bon dans nagios)

    Les chemins semblent (j'ai revérifié au moins 10 fois)

    Par contre qd je lance ods j'ai :

    Possible unintended interpolation of @78 in string at /usr/local/oreon/ODS/etc/conf.pm line 3.

    Le @78 correspond à une partie du password du user de msql.

    Leave a comment:


  • rom
    replied
    Si tu as des '?' c'est que :

    - Nagios est arrete
    - Les javascript ne sont pas actives sur ton navigateur
    - Les chemins vers les fichiers de nagios sont faux

    Si les camemberts sont absent c'est que :

    - Nagios est arrete
    - Les chemins vers les fichiers de nagios sont faux

    Donc, soit :
    - Nagios est arrete
    - Les chemins vers les fichiers de nagios sont faux

    Pense aussi a restarter ods /etc/init.d/ods start

    Leave a comment:


  • Lemmy78
    replied
    Salut,

    Bon je n'ai pas eu le temps de faire les tests Lundi. En fait comme je teste sur un VmWare sous XP, ce matin je redémarre le Vmware - ubuntu - nagios - oreon et là plus de messages d"erreur.

    Mais cela aurait été trop beau, je me retrouve avec "?" dans la ligne des status et plus de graphe sur la page d'accueil !!!!

    Bon je continue à chercher....

    Leave a comment:


  • Lemmy78
    replied
    ok merci

    je vais ça lundi maintenant

    bon WE

    A+

    Leave a comment:


  • rom
    replied
    A cet endroit :
    http://svn.oreon-project.org/svn/Mod...iosImages-1.0/
    (anonymous/anonymous bien sur...)

    J'ai mis un bundle de toutes les images que g trouvé.
    Soit les repertoires un a un, soit l'archive dans archives/

    Dezippez le dans le rep d'images de Nagios

    Leave a comment:


  • rom
    replied
    options generales => Nagios => Images list

    Regarde ce path si il est bon

    Leave a comment:


  • DonKiShoot
    replied
    Vérifie les options de configuration d'oreon

    Leave a comment:


  • Lemmy78
    replied
    Bon j'en vais tellement marre que j'ai upgradé en 1.4. Mais le pbme subsistant toujours j'ai tout désinstallé et réinstallé en 1.4.
    IDEM !!!

    Plus les erreurs suivantes sur la page de config des hosts :

    Warning: opendir(/usr/local/nagios/share/images/logo/) [function.opendir]: failed to open dir: No such file or directory in /usr/local/oreon/www/include/common/common-Func.php on line 903

    Warning: readdir(): supplied argument is not a valid Directory resource in /usr/local/oreon/www/include/common/common-Func.php on line 904

    Warning: closedir(): supplied argument is not a valid Directory resource in /usr/local/oreon/www/include/common/common-Func.php on line 911

    Leave a comment:


  • Lemmy78
    replied
    ouaouh alors là c'est bizarre. Je rentre pour chaque service :
    check_command check_ping!200,0,20%!500,0,60%

    J'enregistre le fichier, je relance, j'ai toujours la même erreur et le fichier revient à la version d'avant sans les lignes de check_command !!!

    Je me dis bon je n'ai peut être pas les yeux en face des trous ce matin donc je recommence, je revérifie avant de lancer la commande que j'ai bien enregistré le fichier et idem.

    Je ne suis pas un pro en Linux mais là je dois que je ne comprends rien !!!

    Leave a comment:


  • Lemmy78
    replied
    ok je vois ce que tu veux dire et effectivement par rapport au fichier host de nagios il maque la ligne check_command.

    Ce que je pige pas c'est pourquoi il parle de la ligne 272 alors que le 1er service est en ligne 74.

    Bon je vais rajouter les lignes manquantes et je vous redis ce qu'il en est.

    MErci

    Leave a comment:


  • rom
    replied
    Et bien je ne vois aucune definition de commande dans ces 3 services.

    Essaie de voir dans les fichiers de conf initiaux quel template avait une commande, et met le a jour dans l'interface, puis regenere.

    Leave a comment:


  • Lemmy78
    replied
    le voici avec le parent :

    define service{
    name generic-service
    service_description generic-service
    is_volatile 0
    active_checks_enabled 1
    passive_checks_enabled 1
    parallelize_check 1
    obsess_over_service 1
    check_freshness 0
    event_handler_enabled 1
    flap_detection_enabled 1
    process_perf_data 1
    retain_status_information 1
    retain_nonstatus_information 1
    notifications_enabled 1
    register 0
    }

    define service{
    name local-service
    service_description local-service
    use generic-service
    max_check_attempts 4
    normal_check_interval 3
    retry_check_interval 1
    check_period 24x7
    notification_interval 60
    notification_period 24x7
    notification_options w,u,c,r
    contact_groups admins
    register 0
    }

    merci

    Leave a comment:


  • rom
    replied
    On peut voir ton template "local-service" ?
    Il manque un element obligatoire dans l'arborescence de ton service, reste a trouver ou.

    Peut etre qu'un element n'a pas ete uploade correctement, cela arrive, les fichiers qui remontent sans prob sont ceux generes par Oreon. On a pas gere tous les mecanismes de Nagios (regexp, ...)

    Leave a comment:

Working...
X