Announcement

Collapse
No announcement yet.

problème installation composants pear

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • problème installation composants pear

    Bonjour,

    je viens tout juste de découvrir oréon via un ami et ce projet me paraît vraiment intéressant, je me suis donc lancé dans l'installation à partir d'une debian3.1. installation nagios et oréon pas de problème particulier apparent.

    Lors du premier test via l'interface web, je constate qu'il me manque des composants pear, j'ai donc testé la commande d'install de ces composants pear :

    pear install -o -f --alldeps DB_DataObject DB_DataObject_FormBuilder MDB2 Date Numbers_Roman Numbers_Words HTML_Common HTML_QuickForm HTML_QuickForm_advmultiselect HTML_Table Auth_SASL Image_Graph Mail_Mime Net_Traceroute Net_Ping Validate

    mon souci c'est que c'est que j'ai un retour du type :

    Starting to download DB_DataObject_FormBuilder-1.0.0RC7.tgz (68,052 bytes)
    ...done: 68,052 bytes
    No handlers for package.xml version 2.0

    et ceci pour tout les package non installé (logique...certains composants sont passés correctement)

    j'ai tenté un pear upgrade-all mais j'ai le même retour d'erreur,

    si vous avez une petite idée ? Je pense que le souci viens de ma version pear installé à priori les composants que je veux installer ne sont pas dispo pour ma version de pear ?

    merci,

  • #2
    Tu as une version trop vieille de "pear". Il faut commencer par le mettre lui-même à jour par les commandes :
    pear upgrade PEAR-1.3.6
    pear upgrade PEAR

    Ainsi, tu auras une version 1.4.*
    Ensuite, tu pourras lancer la grosse commande de pear install

    Comment


    • #3
      tellement simple ..... merci

      à noter que je passe en 1.5.1 quelque soucis de dépendences a forcer avec --alldeps et ça passe.

      Comment

      Working...
      X