Announcement

Collapse
No announcement yet.

Ods

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Ods

    Bonjour,

    Il me semble que j'ai un problème avec l'installation d'ODS.

    La remontée de log fonctionne et c'est déjà un point positif.

    La remontée des infos dans data_bin metrics et index_data semble fonctionnée aussi. Seule la table statistics reste vide.

    Malgré ça dans oréon graph lorsque je choisi un host les images des graphs sont générés mais sans information.

    J'utilise cette commande pour remonter les perfdatas :

    /usr/bin/printf "%b" "$TIMET$\t$HOSTNAME$\t$SERVICEDESC$\t$SERVICEOUTPU T$\t$SERVICESTATE$\t$SERVICEPERFDATA$\n" >> /usr/local/nagios/var/service-perfdata

    Pouvez vous m'aider à résoudre mon problème?

    D'avance merci

  • #2
    Salut,

    Je ne sais pas si ca va t'aider mais moi j'ai ca:

    process-service-perfdata:
    Code:
    TIMET=$1
    HOSTNAME=$2
    SERVICEDESC=$3
    OUTPUT=$4
    SERVICESTATE=$5
    PERFDATA=$6
    PERFFILE="/var/nagios/service-perfdata"
    
    /usr/bin/printf "%b" "$TIMET\t$HOSTNAME\t$SERVICEDESC\t$OUTPUT\t$SERVICESTATE\t$
    PERFDATA\n" >> $PERFFILE
    Perso, je ne comprends pas pourquoi tu as des "$" après chaque non de varables.
    Centreon 2.x

    Comment


    • #3
      Originally posted by WAtt View Post
      Perso, je ne comprends pas pourquoi tu as des "$" après chaque non de varables.
      C'est parce qu'il doit utiliser la commande dans les fichiers de configuration de Nagios et non dans un script à part.

      D'ailleurs à ce propos si quelqu'un sait, pourquoi ne pas utiliser dans nagios.cfg les options suivantes au lieu de passe par le plugin process-service-perfdata :

      service_perfdata_file=/usr/local/nagios/var/service-perfdata
      service_perfdata_file_template=$TIMET$\t$HOSTNAME$ \t$SERVICEDESC$\t$OUTPUT$\t$SERVICESTATE$\t$PERFDA TA$

      Question performance, ça doit aller plus "vite" (Nagios n'a pas besoin de lancer un nouveau process pour exécuter le plugin).

      Comment


      • #4
        Les $ font que ma commande fonctionne je ne passe pas par le fichier process-service-perfdata fourni.

        D'ailleur quel paramètre faut il modifier pour l'utiliser et etre conforme?

        Si quelqu'un a une install complete d'ODS avec des screenshots j'avoue que je suis preneur...

        Merci de votre aide.

        Eventuellement une fois que mon ODS tournera je veux bien vous faire un bout de wiki...

        Comment

        Working...
        X