Announcement

Collapse
No announcement yet.

problème install oreon

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • problème install oreon

    Bonjour a tous.

    J'ai installer apache, mysql, php4, pear, nagios, perhaps puis oreon.

    Le problème c'est que la page http://@de mon server/oreon n'est pas trouver ... je vais alors sur http://@de mon server/oreon/install/setup.php . Mais la mon navigateur veut télécharger setup.php ...

    Le pire c'est que avant sa marchait, mais ma version de pear étais trop vieille pour oreon 1.4, je l'ai donc mis a jour et la paf marche pu ....

  • #2
    Ta conf php/apache est dead.
    Il faut que tu vérifie l'appel au module php dans la conf d'apache.
    Il n'y a pas de mystère, la réponse est surement dans les logs d'erreurs de ton serveur.

    PS: PHP5 obligatoire je crois mais comme je me trompe souvent en ce moment :d
    Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
    Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
    Fedora Core 5 - 2.6.20-1.2320

    Comment


    • #3
      Apparament, seul php pear v5 est nécessaire.

      Enfin faut que je teste. En plus j'ai pris une version stable de Debian, et apparament, php5 n'est pas encore passer en stable, puisque pour passer pear en v5 j'ai du forcer la mise aà jour. Et comme je ne sais pas comment faire pour forcer apt-egt a mettre une version non stable, je vais esseyer de faire marcher le tous comme sa.

      Merci pour ton aide, et effectivement, faut que je déclare le module php dans la conf d'apache, je m'y lance de suite.

      Comment


      • #4
        Bon en faite pour la v1.4 d'Oreon, une version php4.2 ou superieur est acceptée, c'est PEAR qui doit être plus récent.

        En tous cas si un jour quelqu'un à ce problème, voila comment je l'ai résolu :

        Editer /etc/apache2/apache2.conf et y ajouter la ligne suivante :

        Originally posted by /etc/apache2/apache2.conf
        LoadModule php4_module /usr/lib/apache2/modules/libphp4.so
        Ensuite (même si je n'étais pas sûre que ce soit nécessaire), édité /etc/apache2/mods-enabled/*.conf, pour qu'il ressemble à sa :

        Originally posted by etc/apache2/mods-enabled/*.conf
        <IfModule mod_dir.c>

        DirectoryIndex index.html index.cgi index.pl index.php index.xhtml
        AddType application/x-httpd-php .php .php4
        AddType application/x-httpd-php-source .phps

        </IfModule>
        ps : sur une RedHat ou Fedore, il ne faut pas éditer apache2.conf mais httpd.conf

        Comment

        Working...
        X