Announcement

Collapse
No announcement yet.

vérification des composants php

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • anouar
    replied
    slt tor,
    en fait moi aussi je suis dans la meme galere ke toi, j'essaie d'installer un oreon sur un centos 4.4, je suis à l'étape d'install des composants de php, j'ai obtenu des ok au niveau des composants suivants:

    DB OK
    DB_DataObject Failed
    Need DB_DataObject-1.8.4
    DB_DataObject_FormBuilder Failed
    Need DB_DataObject_FormBuilder-1.0.0RC4
    MDB2 Failed
    Need MDB2-2.0.0
    Date Failed
    Need Date-1.4.6
    Numbers_Roman Failed
    Need Numbers_Roman-1.0.1
    Numbers_Words Failed
    Need Numbers_Words-0.14.0
    HTML_Common Failed
    Need HTML_Common-1.2.2
    HTML_QuickForm Failed
    Need HTML_QuickForm-3.2.5
    HTML_QuickForm_advmultiselect Failed
    Need HTML_QuickForm_advmultiselect-1.1.0
    HTML_Table Failed
    Need HTML_Table-1.6.1
    Archive_Tar OK
    Auth_SASL Failed
    Need Auth_SASL-1.0.1
    Console_Getopt OK
    HTTP OK
    Image_Canvas Failed
    Need Image_Canvas-0.2.4
    Image_Color Failed
    Need Image_Color-1.0.2
    Image_Graph Failed
    Need Image_Graph-0.7.1
    Image_GraphViz Failed
    Need Image_GraphViz-1.1.0
    Mail OK
    Mail_Mime OK
    Net_SMTP OK
    Net_Socket OK
    Net_Traceroute Failed
    Need Net_Traceroute-0.21
    Net_Ping Failed
    Need Net_Ping-2.4.1
    Validate Failed
    Need Validate-0.6.2
    XML_RPC OK

    et en tapant :
    pear install -o -f --alldeps DB_DataObject DB_DataObject_FormBuilder MDB2 Date Numbers_Roman Numbers_Words HTML_Common HTML_QuickForm HTML_QuickForm_advmultiselect HTML_Table Auth_SASL Image_Canvas Image_Color Image_Graph Image_GraphViz Mail_Mime Net_Traceroute Net_Ping Validate XML_RPC

    j'ai obtenu le resultat suivant :

    snmp_get_valueretrieval in Unknown on line 0
    PHP Warning: snmp: Unable to register functions, unable to load in Unknown on line 0
    downloading DB_DataObject-1.8.5 ...
    Starting to download DB_DataObject-1.8.5 (61,135 bytes)
    ....done: 61,135 bytes
    Warning: DB_DataObject_FormBuilder is state 'beta' which is less stable than state 'stable'
    downloading DB_DataObject_FormBuilder ...
    Starting to download DB_DataObject_FormBuilder (68,052 bytes)
    ...done: 68,052 bytes
    No handlers for package.xml version 2.0

    je ne sais pas où t'en es de ton coté, moi je suis encore bloqué, donc si jamais ta des propositions n'hesite pas.
    merci d'avance

    Leave a comment:


  • Tor
    replied
    lol!! tu la connai pas? bon courage!

    Leave a comment:


  • pymouse
    replied
    # pear install Date

    # pear install Date
    No releases available for package "pear.php.net/Date"
    Cannot initialize 'Date', invalid or missing package file
    Package "Date" is not valid
    install failed


    D'ou la command : #pear config-set http_proxy 'http://@ipduproxyort'

    faut que je trouve l'adr ip du proxy maintenant

    Leave a comment:


  • Tor
    replied
    normalement en utilisant pear tu n'as pas besoin de telecharger les package pour les installé y les telecharge pour toi!

    Leave a comment:


  • pymouse
    replied
    Hey les gars, moi aussi je suis sur l'installation de Oréon pour un stage, mais je suis sur Red Hat entreprise 4... Me manque des package lié a PEAR...Donc je télécharger les source sur le site web officiel de pear et la :

    # pear install Date-1.4.7.tgz
    The extension 'zlib' couldn't be found.
    Please make sure your version of PHP was built with 'zlib' support.

    Pourtant jai bien mit l'option --with-zlib lors l'installation de PHP (enfin j'ai la verision php 4.3.9 fourni sous red hat 4, met avec le phpinfo() j'ai vu que dans la ligne de commande ./configure il y avait l'option zlib...) :confused: :confused:

    Leave a comment:


  • Tor
    replied
    oki côôl merci!

    Leave a comment:


  • DonKiShoot
    replied
    L'argument est simple : Les composants pear sont fournit par pear.

    Pear est moins contraignant pour les developpeurs car il ne faut pas obligatoirement être un gourou du packaging ni avoir des relations dans ce domaine, ce qui explique cette non présence dans les dépots rpm.
    C'est un choix de pear, on n'y peut rien, on le respecte c tout, sinon on passe son chemin :-D

    Leave a comment:


  • Tor
    replied
    a j'utilise une centos 4.4 aussi mais ça change pas énorme j'pense pas

    Leave a comment:


  • Tor
    replied
    « yum install rrdtool rrdtool-perl perl-GD net-snmp-perl perl-Config-IniFiles perl-Digest-HMAC perl-Digest-SHA1 php-pear php-gd php-snmp php-mysql »
    Pour ça c'est ok j'ai tout installé avec yum

    « pear install -o -f --alldeps Mail Mail_Mime Net_SMTP Net_Socket Net_Traceroute Net_Ping Validate Image_Graph Image_GraphViz HTML_Table HTML_QuickForm_advmultiselect Auth_SASL HTTP Numbers_Roman Numbers_Words MDB2 DB_DataObject_FormBuilder DB_DataObject DB Date »
    Parcontre ça mon maitre de stage voudrai que je le trouve avec yum hors je ne les trouve pas alors qu'avec pear cela fonctionnne trés bien j'voudrais juste des arguments pour lui montré que pear ne va pas rendre instable la platforme (enfin les composants installé avec pear!)
    sinon mon @msn ç [email protected]

    Leave a comment:


  • DonKiShoot
    replied
    Pour Fedora on peut tout faire avec yum sauf pear.
    Je conseil donc pour etre le plus a jour possible :

    « yum install rrdtool rrdtool-perl perl-GD net-snmp-perl perl-Config-IniFiles perl-Digest-HMAC perl-Digest-SHA1 php-pear php-gd php-snmp php-mysql »

    « pear install -o -f --alldeps Mail Mail_Mime Net_SMTP Net_Socket Net_Traceroute Net_Ping Validate Image_Graph Image_GraphViz HTML_Table HTML_QuickForm_advmultiselect Auth_SASL HTTP Numbers_Roman Numbers_Words MDB2 DB_DataObject_FormBuilder DB_DataObject DB Date »

    Personne n'a fait de tuto Fedora sur le wiki ?
    Sinon j'ai ca mais pas au propre et y a encore des copier coller avec des infos confidentiel, je n'ai pas remplacé toutes les ip par des ip bidons, etc ...

    Leave a comment:


  • furtif
    replied
    Msn web messanger si tu veux, enfin bon sa résolvera pas nos probleme

    Leave a comment:


  • Tor
    replied
    bon bin furtif peu pas install msn tanpis

    Leave a comment:


  • Tor
    replied
    Originally posted by Tor View Post
    Bon j'ai une autre petite question!!
    Mon maitre de stage voudrais que je n'utilise que yum pour toute l'installe!
    donc jusqu'a un certain point ça me va mais pour l'install des extensions php je pense que l'utilisation de pear est mieux approprié. En effet avec yum je n'ai pas trouvé les pack nécessaire.
    Quelqu'un a une idée pour que je puisse le convaincre que l'installation des composants php avec pear ne va pas rendre la plateforme instable?
    merci
    quelqu'un a une idée pour ça ! sinon je dl msn furtif

    Leave a comment:


  • furtif
    replied
    Alors commençons.
    En fait pour etre rapide j'ai suivis ce tuto :
    http://www.debianhelp.co.uk/oreon1.3.htm

    Mais pear n'est jamais detecté et meme si une fois il l'a été durant l'installation. Une fois arrivé sur la page install.php, il ne trouvais pas PEAR, ni d'ailleur libexec..etc Pourtant, tout est bien installé. J'ai vérifié les dossiers...etc

    La je commence une install propre sur une Desbian, donc prions un peu ^^
    si tu as un msn, je te filerai le mien si tu veux

    Leave a comment:


  • Tor
    replied
    Bin j'ai pas vraiment d'astuce mais je me suis pas mal galéré a comprendre tout le chmilblic! si tu pouvai etre un peu plus préci sur ce que tu a fait exactement depuis le debut je pourrai peut étre t'aider si biensur tu a eu les mm prob que moi!

    Leave a comment:

Working...
X