Announcement

Collapse
No announcement yet.

vérification des composants php

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Pittocha
    replied
    j'ai rrdtool version 1.0.49, qd je desinstalle et reinstalle la version rrdtool-1.2.18-1 pour red hat el4 le service ods veut plus demarrer.
    si je remet la version 1.0.49 ods remarche... mais bon came genere pas de graph, c'est poru ca que je voulais la mettre à jour...
    quelqu'un peut-il m'aider ?

    d'ailleurs l'install d'une version > à 1.0.49 ca donne :

    [[email protected] rpm_oreon]# rpm -ivh rrdtool-1.2.15-1.el4.rf.i386.rpm perl-rrdtool-1.2.15-1.el4.rf.i386.rpm
    attention: rrdtool-1.2.15-1.el4.rf.i386.rpm: signature V3 DSA: NOKEY, key ID 6b8d79e6
    Préparation... ########################################### [100%]
    1erl-rrdtool ########################################### [ 50%]
    2:rrdtool ########################################### [100%]
    Last edited by Pittocha; 9 May 2007, 09:42.

    Leave a comment:


  • anouar
    replied
    je vous remercie tous pour votre aide

    Leave a comment:


  • Tor
    replied
    bon calme toi...
    ensuite rrdtool a besoin de perl-rrdtool donc dans l'installation des rpm y faut faire comme ça:
    rpm -ivh rrdtool-1.2.15-1.el4.rf.i386.rpm perl-rrdtool-1.2.15-1.el4.rf.i386.rpm
    apres j'te conseil de mettre rrdtool 1.2.18 tu les trouvera facilement sur "rpm search"
    si apres ça ta encore des erreur...

    Leave a comment:


  • BubuLeMag
    replied
    rpm -ivh perl-rrdtool-1.2.15-1.el4.rf.i386.rpm rrdtool-1.2.15-1.el4.rf.i386.rpm

    En mettant les 2 rpms en lignes de commande, il devrait les installer en même temps.

    Leave a comment:


  • clementthersiquel
    replied
    Fait:
    Code:
    rpm -ivh rrdtool-1.2.15-1.el4.rf.i386.rpm perl-rrdtool-1.2.15-1.el4.rf.i386.rpm

    Leave a comment:


  • anouar
    replied
    j'ai déjà essayé cette methode mais à chaque fois, il me sort la meme chose, je t'explique :
    [[email protected] ~]# rpm -ivh rrdtool-1.2.15-1.el4.rf.i386.rpm
    erreur: Dépendances requises:
    perl(RRDp) est nécessaire pour rrdtool-1.2.15-1.el4.rf.i386
    perl(RRDs) est nécessaire pour rrdtool-1.2.15-1.el4.rf.i386
    j'ai cherché sur rpmfind le perl(RRDp), en fait c'est le perl-rrdtool, j'ai telechargé la meme version, et voila le resultat :
    [[email protected] ~]# rpm -ivh perl-rrdtool-1.2.15-1.el4.rf.i386.rpm
    erreur: Dépendances requises:
    /usr/bin/rrdcgi est nécessaire pour perl-rrdtool-1.2.15-1.el4.rf.i386
    librrd.so.2 est nécessaire pour perl-rrdtool-1.2.15-1.el4.rf.i386
    rrdtool = 1.2.15 est nécessaire pour perl-rrdtool-1.2.15-1.el4.rf.i386

    je vais peter un cable, je ne sais plus koi faire!!!!!!!!!

    Leave a comment:


  • Tor
    replied
    y m'avais mi la mm erreur quand je passai par une install de rrdtool ou fallait tout compiler soi mm.
    g donc prit les rpm rrdtool et perl rrdtool et fais
    rpm -ivh "paquet1" paquet2".
    ensuite pour glibc yum trouvait pas non plus (ya d'autre chose qui trouvait pas d'ailleur).
    pour ce cas g fait pareil que pour rrdtool chui allé sur "rpm search" et g dl tout ce qui me manqué voila!!

    Leave a comment:


  • pymouse
    replied
    Il te manque des pakages ...
    Lors de l'installation de nagios 2.5 il te demande si tu veut installer certains packages...
    Enfin moi j'ai pris les sources... ./install-sh j'ai suivi les instructions, a chaque demande d'installation d'un package je vérifié si il été pas déja installer et le cas échant je passé sont installation. De tête me rapel plus ce qui est demandé lors de linstall, mais lib-png me dit quelque chose ^^
    Last edited by pymouse; 26 April 2007, 15:11.

    Leave a comment:


  • anouar
    replied
    je te remercie ça a marché,
    ya un autre probleme dans l'install de nagios, en fait j'arrive pas à trouver le package rtld et j'ai pas pu installer un autre glibc meme avec le yum,
    regarde ce k'il m'affiche quanfd je veux installer le rrdtool:
    Error: Missing Dependency: rtld(GNU_HASH) is needed by package rrdtool
    Error: Missing Dependency: libc.so.6(GLIBC_2.4) is needed by package rrdtool
    Error: Missing Dependency: perl >= 4:5.8.8 is needed by package rrdtool
    Error: Missing Dependency: libpng12.so.0(PNG12_0) is needed by package rrdtool
    Error: Missing Dependency: rtld(GNU_HASH) is needed by package perl-rrdtool
    ??????????

    Leave a comment:


  • Tor
    replied
    Originally posted by anouar View Post
    merci Tor, ça a marché
    j'ai pu installer tous les composants de php, grace à toi.
    maintenant je suis passé à l'étape suivante, qui est Database verification, et le resultat est :
    MySQL version CRITICAL

    Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)

    alors voila tous les pakages installés en rapport avec mysql :
    mysql-server-4.1.20-2.RHEL4.1
    mysql-devel-4.1.20-2.RHEL4.1
    mysqlclient10-3.23.58-4.RHEL4.1
    libdbi-dbd-mysql-0.6.5-10.RHEL4.1
    mysql-4.1.20-2.RHEL4.1
    php-mysql-4.3.9-3.22.4
    mod_auth_mysql-2.6.1-2.2
    mysql-bench-4.1.20-2.RHEL4.1

    est ce que il y a un package manquant?ou bien ya des modif au niveau du script?
    Je te remercie encore
    A tu lancé le service mysqlserver ??
    je pense que le probléme vien de la!! (fin je crois)
    commande:
    service mysqld start
    voila voila!! si d'autre question hésite pas je bosse sur le mm os que toi

    Leave a comment:


  • Locki
    replied
    Mon problème est OK...effectiveemnt c'était un bug dans le path de pear..

    Bon, maintenant j'ai un bug avec mon serveur mysql...je sais pas ce qui se passe, impossible de s'y connecter, je dois indiquer le mauvais password. J'ai fais toutes les étapoes pour rétablir le mot de passe, mais rien n'y fait, toujours impossible...

    comment je peux purger le packet mysql sous suse? Avec debian, c'est --purge, mais avec yast2?

    merci

    Leave a comment:


  • anouar
    replied
    merci Tor, ça a marché
    j'ai pu installer tous les composants de php, grace à toi.
    maintenant je suis passé à l'étape suivante, qui est Database verification, et le resultat est :
    MySQL version CRITICAL

    Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)

    alors voila tous les pakages installés en rapport avec mysql :
    mysql-server-4.1.20-2.RHEL4.1
    mysql-devel-4.1.20-2.RHEL4.1
    mysqlclient10-3.23.58-4.RHEL4.1
    libdbi-dbd-mysql-0.6.5-10.RHEL4.1
    mysql-4.1.20-2.RHEL4.1
    php-mysql-4.3.9-3.22.4
    mod_auth_mysql-2.6.1-2.2
    mysql-bench-4.1.20-2.RHEL4.1

    est ce que il y a un package manquant?ou bien ya des modif au niveau du script?
    Je te remercie encore

    Leave a comment:


  • Tor
    replied
    si ta pas encore trouvé commetn faire voila
    de la FAQ go-pear.org:

    Vous utilisez une version de PEAR inférieure à 1.4.0.

    Pour installer le paquet, vous devez mettre à jour PEAR via la commande :

    $ pear upgrade PEAR

    Ceci va installer la dernière version disponible de PEAR qui sera capable d'installer les paquets qui n'ont qu'un fichier package.xml en version 2.0.

    Si vous avez une ancienne version de PEAR d'installée (i.e. < 1.3.6), vous devez utiliser les deux commandes suivants pour installer la dernière version disponible :

    $ pear upgrade -a PEAR-1.3.6

    $ pear upgrade -a PEAR
    Bon courage !!

    Leave a comment:


  • anouar
    replied
    bonjour tut le monde,
    je suis encore bloqué, il me sort encore des erreurs, j'ai une version de pear 1.3.2 avec une version php 4.3.9, j'ai voulU passer à une autre version de Pear par la commande
    pear install -f pear-1.5.2
    mais ça ne marche pas, il m'affiche les meme erreurs :

    PHP Notice: Constant IMG_GIF already defined in Unknown on line 0
    .......
    PHP Warning: gd: Unable to register functions, unable to load in Unknown on line 0 .......
    PHP Warning: snmp: Unable to register functions, unable to load in Unknown on line 0.....

    j'ai vraiment besoin d'aide.
    Merci

    Leave a comment:


  • furtif
    replied
    Bien De toute, tu bloquera partout Faut ce mettre sa en tete ^^

    Leave a comment:

Working...
X