Announcement

Collapse
No announcement yet.

Problème ODS : base de données vide

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problème ODS : base de données vide

    Bonjour,

    Je suis actuellement en train de mettre en place Nagios/Oreon 1.4 dans le cadre de mon travail.

    J'ai néanmoins un petit problème lors de la mise ne place d'ODS. En effet la base se remplit mais seulement les tables log (1000 et + enregistrement), config (un enregistrement) et statistics (1 enregistrement).

    J'ai bien paramétré Nagios pour qu'il écrive dans un fichier service-perfdata avec la commande process-service-perfdata.
    Le fichier semble bien parsé car en effet service-perfdata se vide ensuite dans service-perfdata.tmp.

    Avez-vous une idée pour résoudre mon problème ?

  • #2
    tu n'as rien dans index_data ?
    Julien Mathis
    Centreon Project Leader
    www.merethis.com |

    Comment


    • #3
      Rien du tout dans les tables index_data, data_bin et metrics.

      Comment


      • #4
        et dans rep_oreon/ODS/var/ods.log tu as des messages d'erreur ?
        Julien Mathis
        Centreon Project Leader
        www.merethis.com |

        Comment


        • #5
          Non j'ai juste ca dans les logs (d'ailleurs ca m'etonne )

          1176795359 - Starting ODS engine...
          1176795359 - PID : 1514
          1176817509 - Starting ODS engine...
          1176817509 - PID : 1583
          1176971533 - Starting ODS engine...
          1176971533 - PID : 3890

          Comment


          • #6
            pourkoi ca t'etonnes ?
            Julien Mathis
            Centreon Project Leader
            www.merethis.com |

            Comment


            • #7
              Ben en fait j'aurais suposé que si y'avait des problèmes ou autres il les aurait loggués.

              Y'a t'il un mode debug ODS ?

              Comment


              • #8
                Aucune idées pour résoudre mon problème ?

                Comment


                • #9
                  Rien de suspect dans le nagios.log?
                  Vérifie ta conf ods et ta commande process-service-perfdata voir si elle passe bien.

                  Comment


                  • #10
                    En ce qui concerne le nagios.log il n'y a rien d'inhabituel, on y voit les notifications normales etc...

                    La conf ODS fonctionne car en effet j'arrive à parser les logs qui sont inclus dans la base mais pas les donnés services et machines.

                    Par contre le fichier service-perfdata.tmp est bien rempli de beaucoup de choses.
                    En fait on dirait que ODS n'arrive pas à parser le service-perfdata, pourtant ya les bonnes permissions dessus et tout et tout.
                    Par contre le service-perfdata se vide bien dans service-perfdata.tmp
                    Last edited by ArnaudP; 23 April 2007, 10:03. Reason: Rajout

                    Comment


                    • #11
                      Est il possible que le problème vienne d'un format de données incorrect contenu dans le fichier ?

                      Comment


                      • #12
                        quelle est le format ?
                        Julien Mathis
                        Centreon Project Leader
                        www.merethis.com |

                        Comment


                        • #13
                          Les datas sont au format :

                          [SERVICEPERFDATA] 1177328273 MACHINE GRAPH-PING 2.075 0.111 GPING OK - round-trip min/avg/max/stddev = 0.475/0.693/1.077/0.334 ms time=0.693ms;20;40;; ok=1
                          [SERVICEPERFDATA] 1177328303 MACHINE GRAPH-PING 2.179 0.002 GPING OK - round-trip min/avg/max/stddev = 1.842/2.233/2.650/0.405 ms time=2.233ms;20;40;; ok=1
                          [SERVICEPERFDATA] 1177328333 MACHINE GRAPH-PING 2.104 0.214 GPING OK - round-trip min/avg/max/stddev = 0.444/0.956/1.914/0.830 ms time=0.956ms;20;40;; ok=1
                          [SERVICEPERFDATA] 1177328363 MACHINE GRAPH-PING 2.244 0.112 GPING OK - round-trip min/avg/max/stddev = 0.631/1.375/1.976/0.684 ms time=1.375ms;20;40;; ok=1
                          [SERVICEPERFDATA] 1177328393 MACHINE GRAPH-PING 2.225 0.260 GPING OK - round-trip min/avg/max/stddev = 1.630/1.731/1.808/0.091 ms time=1.731ms;20;40;; ok=1

                          Comment


                          • #14
                            héhé ha oauis

                            essaye le format suivant

                            $time$\t$hostname$\t$service_description$\t$output $\t$status$\t$perfdata$
                            Julien Mathis
                            Centreon Project Leader
                            www.merethis.com |

                            Comment


                            • #15
                              Je teste et je te dis ca

                              Comment

                              Working...
                              X