Announcement

Collapse
No announcement yet.

Repertoire ODS vide

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • clementthersiquel
    replied
    Il me manquait le module nomme perl-rrdtool. Il me disait qu'il n'arrivait pas a trouver RRDs.pm dans @INC de perl lorsque j'essaye de compiler ods.pl

    Si vous avez d'autres questions..

    Leave a comment:


  • julio
    replied
    Mais de rien...

    Peux tu juste préciser les paquets manquant ou autre, qu'on mette le pb sur le wiki ? ou alors ce que tu as du corriger.

    Merci d'avance

    Leave a comment:


  • clementthersiquel
    replied
    Ca marche
    Alors le probleme c'etait que ods ne s'executait pas vraiment mais bizarrement il sortait pas d'erreur. Les modules perl de rrdtool n'etant pas places au bon endroit, il n'arrivait pas a compiler correctement ods.pl.
    Finalement tout marche correctement.
    Merci beaucoup julio

    Leave a comment:


  • clementthersiquel
    replied
    J'ai peut etre trouve la solution, une histoire avec perl. Je te tiends au courant

    Leave a comment:


  • clementthersiquel
    replied
    J ai tout verifie deux fois et rien ne change... les chemins d installation sont ceux par defaut donc d apres ma capture d ecran du premier post ils sont bons je pense

    Leave a comment:


  • julio
    replied
    regarde bien les chemin de la configuration de ods. Ils ne doivent pas etre bons. verifie bien. Normalement pas besoin de redemarrer apres avoir changé tes chemins.

    Leave a comment:


  • clementthersiquel
    replied
    Non le repertoire ODS est vide. Y'a rien dedans.
    Sinon le service-perfdata est bien dans var, et a force de grossir il fait dans les 10Mo...
    Sinon le service-perfdata.tmp est tellement vide qu'il ne se cree meme pas..

    Leave a comment:


  • julio
    replied
    ton repertoire OreonDataStorage contient bien des bases RRD ?

    Le fichier service-perfdata est bien dans le var de nagios et est il gros ?

    le fichier service-perfdata_tmp est il vide ou quasi ?

    On va trouver t'inkiete pas

    Leave a comment:


  • clementthersiquel
    replied
    desole

    Oui desole julio d'avoir ouvert un post sur ca, mais je n'ai pas trouve la solution dans les precedents.
    Oui j'ai bien active ods

    Code:
    service ods restart
    Stopping ODS Collector : ods_daemon
    Waiting for ods to exit . done.
    Starting ODS Collector : ods_daemon
    En capture d'ecran, ma configuration de ODS.
    Attached Files

    Leave a comment:


  • julio
    replied
    Ne me dis pas que t'a ouvert un nouveau thread pour mettre la suite de ton pb Y en a tellement qui parle deja de tout ca !

    Bon sinon as tu lancé ods ? /etc/init.d/ods start

    c pas forcé qu'il se vide dans le fichier _tmp.. Ca ca s'active dans les options de perfparse.... cf un autre post qui parle de perfdata_file et drop_file....

    Leave a comment:


  • clementthersiquel
    started a topic Repertoire ODS vide

    Repertoire ODS vide

    J'ai tout reinstalle et j'ai encore des problemes...
    Alors j'ai nagios 2.5, oreon 1.4, rrdtool 1.2.18, tous les patchs oreon appliques, et tous les paths nien configures normalement.
    Le probleme c'est que le repertoire ODS reste vide, que le fichier service-perfdata se rempli, mais ne se vide jamais dans service-perfdata.tmp.
    Par contre il y a bien des fichiers generes dans rrd.
    Je sais pas ce qui ne fonctionne pas.
    Merci d'avance
Working...
X