Announcement

Collapse
No announcement yet.

installing the web interface

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • installing the web interface

    Hi all,

    I'm having a few issues with the http://server_name/oreon/install/setup.php
    setup. Currently I'm stuck at the Verifiying PHP Pear Components

    Component Status
    PHP Pear Extension
    DB OK
    DB_DataObject Failed
    Need DB_DataObject-1.8.4
    DB_DataObject_FormBuilder Failed
    Need DB_DataObject_FormBuilder-1.0.0RC4
    MDB2 Failed
    Need MDB2-2.0.0
    Date Failed
    Need Date-1.4.6
    Numbers_Roman Failed
    Need Numbers_Roman-1.0.1
    Numbers_Words Failed
    Need Numbers_Words-0.14.0
    HTML_Common Failed
    Need HTML_Common-1.2.2
    HTML_QuickForm Failed
    Need HTML_QuickForm-3.2.5
    HTML_QuickForm_advmultiselect Failed
    Need HTML_QuickForm_advmultiselect-1.1.0
    HTML_Table Failed
    Need HTML_Table-1.6.1
    Archive_Tar OK
    Auth_SASL Failed
    Need Auth_SASL-1.0.1
    Console_Getopt OK
    HTTP OK
    Image_Canvas Failed
    Need Image_Canvas-0.2.4
    Image_Color Failed
    Need Image_Color-1.0.2
    Image_Graph Failed
    Need Image_Graph-0.7.1
    Image_GraphViz Failed
    Need Image_GraphViz-1.1.0
    Mail OK
    Mail_Mime Failed
    Need Mail_Mime-1.3.1
    Net_SMTP OK
    Net_Socket OK
    Net_Traceroute Failed
    Need Net_Traceroute-0.21
    Net_Ping Failed
    Need Net_Ping-2.4.1
    Validate Failed
    Need Validate-0.6.2
    XML_RPC OK
    Run this shell command under root user :
    pear install -o -f --alldeps DB_DataObject DB_DataObject_FormBuilder MDB2 Date Numbers_Roman Numbers_Words HTML_Common HTML_QuickForm HTML_QuickForm_advmultiselect HTML_Table Auth_SASL Image_Canvas Image_Color Image_Graph Image_GraphViz Mail_Mime Net_Traceroute Net_Ping Validate

    I ran the pear install -o -f --alldeps and restarted the linux box but still having the same issue.

    Do I need to install more componets of PHP Pear? This is the error I'm getting after running the pear install -o -f --alldeps
    PHP Warning: Unknown(): Unable to load dynamic library '/usr/lib/php4/snmp.so' - /usr/lib/php4/snmp.so: cannot open shared object file: No such file or directo ry in Unknown on line 0

    ***and***

    downloading DB_DataObject-1.8.5.tgz ...
    Starting to download DB_DataObject-1.8.5.tgz (61,135 bytes)
    ...............done: 61,135 bytes
    Warning: DB_DataObject_FormBuilder is state 'beta' which is less stable than sta te 'stable'
    downloading DB_DataObject_FormBuilder-1.0.0RC7.tgz ...
    Starting to download DB_DataObject_FormBuilder-1.0.0RC7.tgz (68,052 bytes)
    ...done: 68,052 bytes
    No handlers for package.xml version 2.0

    I'm looking all over the place for some answers but deceided to post here to see if anyone else has had this problem.

    Thanks in advance

  • #2
    maybe you need php-snmp and some xml component
    Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
    Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
    Fedora Core 5 - 2.6.20-1.2320

    Comment


    • #3
      I got it installed and working. Now going thru the host setups. wish me luck guys.

      Comment


      • #4
        So how did you sort this out?

        Comment

        Working...
        X