Announcement

Collapse
No announcement yet.

Problème de Graphes

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problème de Graphes

    Bonjour,

    Aprés plusieur jours de galère pour installer correctement Oreon et Nagios, me reste un gros souci. J'ai créer 3 Hosts, 1 Host group et des services(avec chek_graph_ping par exemple)...Je vais dans Configuration->nagios-> générer :

    Code:
    Nagios 2.5
    Copyright (c) 1999-2006 Ethan Galstad (http://www.nagios.org)
    Last Modified: 07-13-2006
    License: GPL
    
    Reading configuration data...
    
    Running pre-flight check on configuration data...
    
    Checking services...
    Checked 4 services.
    Checking hosts...
    Checked 3 hosts.
    Checking host groups...
    Checked 1 host groups.
    Checking service groups...
    Checked 1 service groups.
    Checking contacts...
    Checked 1 contacts.
    Checking contact groups...
    Checked 1 contact groups.
    Checking service escalations...
    Checked 0 service escalations.
    Checking service dependencies...
    Checked 0 service dependencies.
    Checking host escalations...
    Checked 0 host escalations.
    Checking host dependencies...
    Checked 0 host dependencies.
    Checking commands...
    Checked 47 commands.
    Checking time periods...
    Checked 4 time periods.
    Checking extended host info definitions...
    Checked 3 extended host info definitions.
    Checking extended service info definitions...
    Checked 4 extended service info definitions.
    Checking for circular paths between hosts...
    Checking for circular host and service dependencies...
    Checking global event handlers...
    Checking obsessive compulsive processor commands...
    Checking misc settings...
    
    Total Warnings: 0
    Total Errors: 0
    
    Things look okay - No serious problems were detected during the pre-flight check
    Super pas de problèmes !!
    Je vais dans Reporting Host et la pas d'informations sur mes Host (juste pending), je regarde dans les dossier path_oreon/OreonDataStorage -> vide path_oreon/rrd -> vide...

    Qu'est-ce que j'ai oublié de faire ? :confused:

  • #2
    salut,

    il faut que tu selectionnes :
    - Deplacer les fichier => oui
    - Recharger nagios => oui, Reload
    - Generer

    Sinon tu testes juste ta conf sans la deployer.
    ..()_() .°("who | grep -i blonde | date; cd ~; unzip;")
    =(o_0)=
    *(() () Nicolas Verriest, France

    Comment


    • #3
      Code:
      Nagios 2.5
      Copyright (c) 1999-2006 Ethan Galstad (http://www.nagios.org)
      Last Modified: 07-13-2006
      License: GPL
      
      Reading configuration data...
      
      Running pre-flight check on configuration data...
      
      Checking services...
      Checked 4 services.
      Checking hosts...
      Checked 3 hosts.
      Checking host groups...
      Checked 1 host groups.
      Checking service groups...
      Checked 1 service groups.
      Checking contacts...
      Checked 1 contacts.
      Checking contact groups...
      Checked 1 contact groups.
      Checking service escalations...
      Checked 0 service escalations.
      Checking service dependencies...
      Checked 0 service dependencies.
      Checking host escalations...
      Checked 0 host escalations.
      Checking host dependencies...
      Checked 0 host dependencies.
      Checking commands...
      Checked 47 commands.
      Checking time periods...
      Checked 4 time periods.
      Checking extended host info definitions...
      Checked 3 extended host info definitions.
      Checking extended service info definitions...
      Checked 4 extended service info definitions.
      Checking for circular paths between hosts...
      Checking for circular host and service dependencies...
      Checking global event handlers...
      Checking obsessive compulsive processor commands...
      Checking misc settings...
      
      Total Warnings: 0
      Total Errors: 0
      
      Things look okay - No serious problems were detected during the pre-flight check
      
      cgi.cfg - déplacement OK
      checkcommands.cfg - déplacement OK
      contactgroups.cfg - déplacement OK
      contacts.cfg - déplacement OK
      dependencies.cfg - déplacement OK
      escalations.cfg - déplacement OK
      hostextinfo.cfg - déplacement OK
      hostgroups.cfg - déplacement OK
      hosts.cfg - déplacement OK
      misccommands.cfg - déplacement OK
      nagios.cfg - déplacement OK
      resource.cfg - déplacement OK
      serviceextinfo.cfg - déplacement OK
      servicegroups.cfg - déplacement OK
      services.cfg - déplacement OK
      timeperiods.cfg - déplacement OK
      Toujours rien, mes hosts ne sont ni en down ni un up...rien...Il n'y a rien a faire au niveau des hosts ? Juste lancer le service snmp?

      Originally posted by NoS
      Sinon tu testes juste ta conf sans la deployer.
      C'est à dire ?

      Comment


      • #4
        Salut

        Je suis pas depuis longtemps sur nagios/oreon et je galère pas mal.
        J'ai toujours des problème avec les check_graph_* et les traps snmp.

        Le test le plus simpler pour vérifier la bonne génération de conf c'est "check host alive": Pas de paramètres, pas d'agents a implanter...
        Si tu ne mets que ca ca te donne quoi?

        L M
        Debian r4 - Nagios 2.9 - Oreon 1.4
        rrdtool 1.2 - plugin 1.4.8

        Comment


        • #5
          J'ai donc crée un service check_alive :
          période : 24x7
          commande check : check_host_alive
          argument :
          nb max essais : 10
          Ordonnancement régulier : 1 * 60 secondes
          Ordonnancement non régulier : 1 * 60 secondes
          Activation du gestionnaire d'évènements : (x) Défaut
          Commande associée :
          Arguments :
          Controles actifs : (x) Défaut
          Controles passifs : (x) Défaut

          dans les relations j'ai rajouté un host

          la génération de nagios OK

          toujours rien ...

          Par contre, dans Fiches d'Identitées -> serveur j'ai plein d'information sur mes hosts donc elles sont bien reconnu non ?

          Comment


          • #6
            Pour les Fiches d'Identitées c'est lié à la présence d'agent snmp sur tes hosts, c'est pas lié aux services.

            Pour tes hosts, tu as associé quoi comme commande de check?
            En fait en général, je fais un "check host alive" sur mon host et je lui ajoute un service un peu plus complet.
            et quel temps pour "Interval de notification"?

            Je me pose une question: Est-ce qu'une erreur m'était renvoyé quand je n'avais pas completer la partie "utilisateur"? Je sais que par défaut l'utilisateur admin n'était pas complètement configuré, certain champ restait à completer.
            Debian r4 - Nagios 2.9 - Oreon 1.4
            rrdtool 1.2 - plugin 1.4.8

            Comment


            • #7
              En faite j'ai trois hosts et j'ai bien associé check_host_alive, avec un interval de notification à 1 minute (1*60s)

              Je susi d'accord avec toi mon utilisateur n'été pas totalement configurer de base, mais je l'ai complété déjà :

              HOST
              Choix de notifications pour les Hosts : (x) Down
              Période de notification pour les Hosts : 24x7
              Commandes de notifications pour les Hosts : j'ai tout rajouté

              SERVICE
              Choix de notifications pour les Services : (x) Warning
              Période de notification pour les Services : 24x7
              Commandes de notifications pour les Services : tout rajouté aussi

              Comment


              • #8
                Il te donne quoi maintenant?
                Debian r4 - Nagios 2.9 - Oreon 1.4
                rrdtool 1.2 - plugin 1.4.8

                Comment


                • #9
                  Toujours pareils puisque j'avais déja été trifouillé dans les conf utilisateur.

                  Je n'ai aucunes host dans Monitoring -> hosts pareil pour Monotiring -> Service.

                  En haut à droite de l'interface, les 2 tableaux Status des Hotes et Status des Services tout à 0 ... Ce qui me semble normal.

                  Ne serait-ce pas du a une movaise installation de Nagios ? J'ai juste lancé l'installation 2.5 fournie par Oreon, je n'ai pas été sur l'interface web...Il y a peut etre une configuration a faire? Pourtant avec l'interface Oreon je gérère bien les fichier Nagios...:rolleyes:

                  Comment


                  • #10
                    Va voir sur ton interface web de nagios si il y a quelque chose
                    http://@[email protected]/nagios/
                    Oreon 1.4
                    Nagios 2.9
                    RRDTool 1.2.18

                    Comment


                    • #11
                      J'ai moi meme installé la version de nagios by oreon 2.5 et Oreon 1.4
                      Je suis presque jamais allé sur l'interface de Nagios.
                      Je passe soit par Oreon soit en ligne de commande par ssh.
                      Donc le problème ne viens pas de là.

                      Ce qui est bizarre c'est que tu as bien tes hosts et services dans configuration et rien dans monitoring alors que ta config à l'air de passer...

                      Je vois pas d'où ca peut venir, tu as eu des probleme durant l'install?
                      Moi, une fois que j'ai réussi l'install, j'ai créé un autre serveur virtuel depuis le début pour ne plus avoir d'erreur.

                      désolé
                      Debian r4 - Nagios 2.9 - Oreon 1.4
                      rrdtool 1.2 - plugin 1.4.8

                      Comment


                      • #12
                        Nan je n'ai pas eu d'erreur a l'installation, et je n'arrive pas a trouve de fichier de error_log ou je sais pas pour essayer de trouver l'erreur justement ^^

                        Comment


                        • #13
                          On dit toujours que la nuit porte conseil, mais la je susi toujours bloqué ops:

                          Comment


                          • #14
                            Pour moi elle a porté conseil, j'ai résolu mon problème de graph grace a clementthersiquel.
                            Par contre pour toi, j'ai plus aucune idée. Il faudrait quelqu'un qui a déjà eu le problème.
                            Debian r4 - Nagios 2.9 - Oreon 1.4
                            rrdtool 1.2 - plugin 1.4.8

                            Comment


                            • #15
                              Il n'y a rien a faire au niveau de mes HOST ? es-ce que ca ne serait pas un problème avec rrdtool ? mais je n'arrive pas a voir d'ou vien l'erreur c'est ca qui m'énerve...:mad: :mad:

                              Comment

                              Working...
                              X