Announcement

Collapse
No announcement yet.

Probleme de Locales sous Debian : plus de graphiques

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Probleme de Locales sous Debian : plus de graphiques

    Bonjour à tous,

    J'ai redémarré ma Debian et j'ai un souci avec les "Locales" : j'ai tenté de mettre FR_UTF8 :

    Code:
     dpkg-reconfigure locales
    Generating locales (this might take a while)...
      fr_FR.UTF-8... done
    Generation complete.
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
            LANGUAGE = (unset),
            LC_ALL = (unset),
            LANG = "[email protected]"
        are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
            LANGUAGE = (unset),
            LC_ALL = (unset),
            LANG = "[email protected]"
        are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    Du coup, je n'ai plus les graphiques, j'ai eu droit à plein d'erreur Locales dans les fichiers de log Oreon.

    Comment corriger cela ?

    En attendant, mon fichier "2626192 Apr 30 09:05 service-perfdata" se remplit et dès le souci de Locales corrigé, il reprendra les données pour les mettre en BDD car en ce moment la taille de la BDD n'augmente plus et cela est dû aux "locales" d'après ce que je vois.

    Merci !

    Code:
    debian:~# locale
    locale: Cannot set LC_CTYPE to default locale: No such file or directory
    locale: Cannot set LC_MESSAGES to default locale: No such file or directory
    locale: Cannot set LC_ALL to default locale: No such file or directory
    [email protected]
    LC_CTYPE="[email protected]"
    LC_NUMERIC="[email protected]"
    LC_TIME="[email protected]"
    LC_COLLATE="[email protected]"
    LC_MONETARY="[email protected]"
    LC_MESSAGES="[email protected]"
    LC_PAPER="[email protected]"
    LC_NAME="[email protected]"
    LC_ADDRESS="[email protected]"
    LC_TELEPHONE="[email protected]"
    LC_MEASUREMENT="[email protected]"
    LC_IDENTIFICATION="[email protected]"
    LC_ALL=

  • #2
    Pour ceux que ça intéresse, voici ce que j'ai fait :

    dpkg-reconfigure locales
    Puis j'ai choisi : "[email protected]" et le probleme a disparu.

    debian:~# dpkg-reconfigure locales
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
    LANGUAGE = (unset),
    LC_ALL = (unset),
    LANG = "[email protected]"
    are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    locale: Cannot set LC_CTYPE to default locale: No such file or directory
    locale: Cannot set LC_MESSAGES to default locale: No such file or directory
    locale: Cannot set LC_ALL to default locale: No such file or directory
    /usr/bin/locale: Cannot set LC_CTYPE to default locale: No such file or directory
    /usr/bin/locale: Cannot set LC_MESSAGES to default locale: No such file or directory
    /usr/bin/locale: Cannot set LC_ALL to default locale: No such file or directory
    Generating locales (this might take a while)...
    [email protected] done
    Generation complete.

    debian:~# /usr/bin/locale
    [email protected]
    LC_CTYPE="[email protected]"
    LC_NUMERIC="[email protected]"
    LC_TIME="[email protected]"
    LC_COLLATE="[email protected]"
    LC_MONETARY="[email protected]"
    LC_MESSAGES="[email protected]"
    LC_PAPER="[email protected]"
    LC_NAME="[email protected]"
    LC_ADDRESS="[email protected]"
    LC_TELEPHONE="[email protected]"
    LC_MEASUREMENT="[email protected]"
    LC_IDENTIFICATION="[email protected]"
    LC_ALL=
    debian:~#

    Comment


    • #3
      Bon, j'ai redémarré pour tester et j'ai toujours ce message dans les logs :

      Code:
      perl: warning: Setting locale failed.
      perl: warning: Please check that your locale settings:
              LANGUAGE = (unset),
              LC_ALL = (unset),
              LANG = "fr_FR.UTF-8"
          are supported and installed on your system.
      perl: warning: Falling back to the standard locale ("C").
      Une idée pour que cela fonctionne même après un reboot ?

      Comment


      • #4
        J'ai mis les fr_fr et en relançant ODS c'est bon.

        Je vais redémarrer pour voir

        Comment


        • #5
          Bonjour,

          Ca m'interesse, est ce que c'est bon pour toi en mettant FR_Fr?
          Centreon Enterprise Server 3
          Centreon 3

          Comment


          • #6
            J'ai mis le [email protected] et c'est bon.

            Je n'ai pas mis les 3 FR finalement Seulement celui avec euro dedans.

            Comment


            • #7
              Merci pour ta réponse rapide, je viens juste de le régler
              Maintenant mon souci est d'avoir de bon graph (ca fonctionne mais les valeurs renvoyées pour les disques sont fausses).
              Centreon Enterprise Server 3
              Centreon 3

              Comment


              • #8
                Bonjour,

                J'ai fait la meme chose que vous sauf que j'ai :

                dpkg-reconfigure locales
                Generating locales (this might take a while)...
                [email protected] done
                Generation complete.

                /usr/bin/locale
                LANG=
                LC_CTYPE="POSIX"
                LC_NUMERIC="POSIX"
                LC_TIME="POSIX"
                LC_COLLATE="POSIX"
                LC_MONETARY="POSIX"
                LC_MESSAGES="POSIX"
                LC_PAPER="POSIX"
                LC_NAME="POSIX"
                LC_ADDRESS="POSIX"
                LC_TELEPHONE="POSIX"
                LC_MEASUREMENT="POSIX"
                LC_IDENTIFICATION="POSIX"
                LC_ALL=

                Une idée ?

                Comment

                Working...
                X