Announcement

Collapse
No announcement yet.

[regle] Pb graphes - Tous les id.rrd a 1

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [regle] Pb graphes - Tous les id.rrd a 1

    suite à la migration qui s'est tres bien passée, je souhaiterais résoudre un dernier pb : la génération de graphes:
    tous mes graphes se créent sous l'indice 1.rrd et lorsque je veux les afficher, les graphes sont biensur introuvable puisque l'indice cherché est 201.rdd, etc.

  • #2
    Comment cela est ce possible que tu es toujours cette erreur !!!!
    Dans la table graphs, tu as combien de lignes ?
    Romain Le Merlus
    Centreon Forge
    MERETHIS

    Comment


    • #3
      3 avec les id 306, 307 , 317 (et 3 autres que j'ai essayé de modier en 1, 2 et 3 mais bon ca marche pas mieux...)

      Comment


      • #4
        Et c'est le nombre total de services que tu graphes 3 ? Ou il t'en manque deja a ce niveau la ?
        Romain Le Merlus
        Centreon Forge
        MERETHIS

        Comment


        • #5
          j'ai bien trois services définis.

          Comment


          • #6
            qu'est ce qu'il ne va pas alors?

            Comment


            • #7
              Est ce que tu peux me donner pour un de tes services graphes qui ne fonctionnent pas :

              L'id du service.
              Le command_command_id_arg en BASE pour ce service.
              Romain Le Merlus
              Centreon Forge
              MERETHIS

              Comment


              • #8
                pour un check_graph_ping :
                L'id du service : 306
                Le command_command_id_arg en BASE pour ce service. : 56

                Comment


                • #9
                  Bon alors je ne comprends pas trop comment ca a pu etre modifie mais le probleme vient de la.

                  En fait quand on graphe, on a besoin de l'id du service pour creer la base rrd correspondante (ca tu dois commencer a le savoir :P )
                  Cet id on le concatene a la fin de l'argument pour le check_graph_xxx

                  Il faut donc que le dernier argument soit celui du service, pour ton cas remplace donc 56 par 306.

                  :!: Uniquement pour les services graphes
                  :!: A faire en base car dans un souci de transparence, l'id n'apparait pas sur l'interface.
                  Romain Le Merlus
                  Centreon Forge
                  MERETHIS

                  Comment


                  • #10
                    desolee je me suis plantée... ops:
                    Le command_command_id_arg en BASE pour ce service est deja 306...

                    Comment


                    • #11
                      ce qui est bizarre c'est que qd je fais un
                      check_graph_ping -H 192.168.x.x -g -D /usr/local/oreon/rrd/ -S 5
                      en étant connecté avec l'utilisateur nagios, ca marche! : le fichier 5.rrd est créé...

                      Comment


                      • #12
                        j'ai comme un doute...
                        est ce que la ligne de commande dans checkcommand.cfg est correcte :
                        $USER1$/check_graph_ping.pl -H $HOSTADDRESS$ -g -D /usr/local/oreon/rrd/

                        Il manque pas un -S $ARG1$ meme si aucun argument est nécessaire (puisque le paramètre est rentré automatiquement)?

                        Comment


                        • #13
                          Bien vu oui c la.

                          $USER1$/check_graph_ping.pl $HOSTADDRESS$ -g -S $ARG1$

                          On enleve juste l'argument dans la saisie mais pas dans les commandes.
                          Romain Le Merlus
                          Centreon Forge
                          MERETHIS

                          Comment

                          Working...
                          X