Announcement

Collapse
No announcement yet.

Installation sur red hat entreprise 4 modifié

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Installation sur red hat entreprise 4 modifié

    Bonjour,
    je voudrais installé oreon sur un serveur sous red hat entreprise 4.
    Ce n'est pas un standard pas mal de chose sont changé dessus chemin d'installe de apache...
    j'ai essayer d'installer install_nagios2.5_by_oreon-v1 mais rien ne s'installe.
    Par exemeple je dis oui a rrdtool. l'install dis ok
    Mais avec un rpm -qa rrdtool je n'ai rien donc il n'est pas installé.
    Donc si quelq'un peut m'aider à installer cette bete (Oreon) je serais tres tres content.
    La red hat est un peu modifier c'est un choix de la boite ou je suis (je ne donnerais pas le nom)
    Merci encore

  • #2
    Salut,

    Je ne crois pas que l'installateur Nagios d'oreon install des RPMs.. donc il est normal que tu n'es rien avec la commande rpm -qa.

    Encore une fois, je conseil (c'est perso), d'utiliser un maximum de paquet de redhat (ta distrib) pour toutes les applications supportées par Redhat (histoire de support/mise a jour/garanti....)

    Donc tu installes tt les RPM qui vont bien et qui seront donc visible avec la commande rpm -qa, ensuite tu installes Oreon depuis la version dispo sur le site (n'oublies pas les patch, premier lien de ma signature)

    Bon courage
    Centreon 2.x

    Comment


    • #3
      merci pour tes conseils.
      Mais qui aurait la liste de toutes les dependances de oreon, nagios?
      Merci

      Comment


      • #4
        http://www.oreon-project.org/pre-req...eon-1.3.x.html
        Centreon 2.x

        Comment


        • #5
          je suis en trian d'écrire un tutoo personalisé pour une red hat 4 es
          contact moi par mp si sa st'interesse
          RedHat4es
          Nagios 2.9
          Oreon 1.4

          Comment


          • #6
            Il faut surtout pas hésité a mettre sur le wiki
            Centreon 2.x

            Comment


            • #7
              oui je sais bien mais j'ai des erreurs de ....
              []# rpm -i rrdtool-1.2.18-1.el4.rf.i386.rpm
              attention: rrdtool-1.2.18-1.el4.rf.i386.rpm: signature V3 DSA: NOKEY, key ID 6b8d79e6
              erreur: Dépendances requises:
              perl(RRDp) est nécessaire pour rrdtool-1.2.18-1.el4.rf.i386
              perl(RRDs) est nécessaire pour rrdtool-1.2.18-1.el4.rf.i386
              perl(Time::HiRes) est nécessaire pour rrdtool-1.2.18-1.el4.rf.i386
              []# perl -e 'use Time::HiRes'
              []#
              donc je ne sais pas ce qu'est perl(RRDp) et perl(RRDs) par contre perl(Time::HiRes) est installer mais non
              je suis completement perdu :confused: :confused: :confused:

              Comment


              • #8
                j'ai le meme probléme
                mais c pas bon faut pas installé comme sa
                voila le debut de ma doc
                mais je suis bloqué a ce foutu pear!
                I/ Configuration proxy wget et apt-get:
                voir ici:
                Configuration du proxy:
                POUR WGET:
                Pout utiliser wget derrière un proxy qui requiert une authentification, il suffit de modifier le fichier :
                # nano /etc/wgetrc
                http_proxy = http://login[email protected]:8080
                proxy = on
                download des packetages
                # wget http://dag.wieers.com/rpm/packages/a...l4.rf.i386.rpm
                # rpm -ivh apt-0.5.15lorg3.1-4.el4.rf.i386.rpm
                # wget http://dag.wieers.com/rpm/packages/r...l4.rf.i386.rpm
                # rpm -ivh rpmforge-release-0.3.4-1.el4.rf.i386.rpm
                Cnfigurer le proxy de apt si necessaire:
                # nano/etc/apt/apt.conf
                rajouter:
                Acquire::http::Proxy "http://toto:[email protected]:8888";
                # apt-get update
                Finich!

                II/ prérequis:

                # up2date -i httpd libtool-libs gd perl-Digest-HMAC perl-Digest-SHA1 mysql-server php php-gd php-mysql php-pear php-snmp php-ldap gd-devel perl-Time-HiRes net-snmp libpng libpng-devel pkgconfig glib2 glib2-devel mysql-devel xorg-x11-devel libjpeg-devel php-xmlrpc

                # apt-get install nagios fping nagios-plugins perl-Crypt-DES perl-Net-SNMP
                perl-Socket6 rrdtool perl-rrdtool perl-GD perl-IO-Socket-INET6 php-pear-mail_mime
                perl-Config-IniFiles

                III/ Instalation de pear:
                III.1 Config proxy pear:
                # pear config-set http_proxy 'http://login[email protected]:8080'
                2. Install packtage pear
                # pear upgrade -a PEAR-1.3.6
                # pear upgrade Archive_Tar
                # pear upgrade Structures_Graph
                # pear upgrade DB
                # pear upgrade PEAR
                # pear channel-update pear.php.net
                # pear upgrade-all

                3.install plugin

                # pear install -o -f --alldeps DB_DataObject DB_DataObject_FormBuilder MDB2 Date
                Numbers_Roman Numbers_Words HTML_Common HTML_QuickForm HTML_QuickForm_advmultiselect
                HTML_Table Auth_SASL Image_Canvas Image_Color Image_Graph Image_GraphViz
                Net_Traceroute Net_Ping Validate
                et voila et je bloque a pear car j'ia ce genre de message:
                [[email protected] staginfo]# pear install -o -f --alldeps DB_DataObject DB_DataObject_FormBuilder MDB2 Date Numbers_Roman Numbers_Words HTML_Common HTML_QuickForm HTML_QuickForm_advmultiselect HTML_Table Auth_SASL Image_Canvas Image_Color Image_Graph Image_GraphViz Net_Traceroute Net_Ping Validate
                downloading DB_DataObject-1.8.5.tgz ...
                Starting to download DB_DataObject-1.8.5.tgz (61,135 bytes)
                ...............done: 61,135 bytes
                Warning: DB_DataObject_FormBuilder is state 'beta' which is less stable than state 'stable'
                downloading DB_DataObject_FormBuilder-1.0.0RC7.tgz ...
                Starting to download DB_DataObject_FormBuilder-1.0.0RC7.tgz (68,052 bytes)
                ...done: 68,052 bytes
                No handlers for package.xml version 2.0
                si quelqu'un puisse m'aider please
                RedHat4es
                Nagios 2.9
                Oreon 1.4

                Comment


                • #9
                  de toutes façon moi je ne peux pas sortir mon serveur est dans une DMZ.
                  Donc c'est loin très loin d'etre gagner non?

                  Comment


                  • #10
                    oui
                    car je pense qeu tu vas étre obligé de chopé les rpm un par un
                    et c'est la merde
                    donc je sais pas comment faire
                    RedHat4es
                    Nagios 2.9
                    Oreon 1.4

                    Comment


                    • #11
                      Originally posted by le_jurassien View Post
                      de toutes façon moi je ne peux pas sortir mon serveur est dans une DMZ.
                      Donc c'est loin très loin d'etre gagner non?
                      Comment ca ? tu n'as pas un serveur de test ? Un serveur dans un réseau de test histoire de faire une maquette avant de mettre en prod ?
                      Centreon 2.x

                      Comment


                      • #12
                        je suis sur un serveur de test on en a 40 juste pour mon service.
                        Je suis dans un très grand groupe donc je gere pas le reseaux :/
                        donc pas le choix :/
                        il faut aussi que le serveur soit installable facilement dans cette configuration réseau.

                        Comment


                        • #13
                          En une seconde sur google, première réponse :

                          Code:
                          Why do I get "No handlers for package.xml     version 2.0" when I try to install a package?
                          
                                You are using a PEAR version lower than 1.4.0.
                                To install the package, you have to update PEAR via:
                                $ pear upgrade PEAR
                                This will install the latest available version of PEAR which     is capable of installing packages that have only a package.xml     version 2.0.
                          Pénible les stagiaires crosoft
                          Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
                          Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
                          Fedora Core 5 - 2.6.20-1.2320

                          Comment


                          • #14
                            Originally posted by DonKiShoot View Post
                            Pénible les stagiaires crosoft
                            Comment tu devines ça ?
                            Centreon 2.x

                            Comment


                            • #15
                              Originally posted by WAtt View Post
                              Comment tu devines ça ?
                              Ils n'ont pas le reflexe www.googole.fr :razz:
                              Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
                              Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
                              Fedora Core 5 - 2.6.20-1.2320

                              Comment

                              Working...
                              X