Announcement

Collapse
No announcement yet.

Vous n'êtes pas .... + DB_Error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts
    julio76520
    Junior Member

  • julio76520
    replied
    Ok tu lances un mysqld --sql-mode="" pour démarrer sql ?

    Moi ca ne marche pas pourtant j'ai refai le setup !!

    Leave a comment:

  • Guigui2607
    Senior Member

  • Guigui2607
    replied
    Pour ma part, c'était comme calcejo, il a fallut que je change le "mode sql" pour autoriser les valeurs nulles...

    J'utilise l'option --sql-mode="" pour démarrer Mysql...
    Je ne sais pas si c'est la meilleure solution, mais en tout cas, ça fonctionne...

    Leave a comment:

  • julio76520
    Junior Member

  • julio76520
    replied
    ok et alors comment fait-on pr résoudre le problème ?

    Leave a comment:

  • Guigui2607
    Senior Member

  • Guigui2607
    replied
    Salut,
    J'ai le même souci :roll: avec MySQL 5.0.45.
    calcejo, tu peux détailler un peu plus ce que tu as fait pour résoudre le problème ?
    Merci d'avance :wink:

    EDIT: C'est tout bon, j'ai résolu le problème :wink:
    Guigui2607
    Senior Member
    Last edited by Guigui2607; 28 February 2008, 14:04.

    Leave a comment:

  • calcejo
    Junior Member

  • calcejo
    replied
    Salut,
    mysql 5.0.2 + sql_mode='traditional' n'aime pas les insert/update avec '' a la place de NULL pour les champs en auto increment

    j'ai tenté une modif des fichiers insert*.sql dans le répertoire ou est localisé le setup.php avec la commande vi : 1,$,s/VALUES (''/VALUES (NULL/g
    suppression des bases centreon + storage
    relancer le setup.
    et là, magie, ca fonctionne correctement !

    ++ : joel

    Leave a comment:

  • lepage
    Junior Member

  • lepage
    replied
    j'ai trouvé le problème. Dans les template de création des tables. par exemple pour la table Topology, il y a des valeurs non définies '' à la place d'un 'NULL' ce qui fait que si votre MySql est en TRADITIONAL mode les lignes ne sont pas insérées dans la table.

    Salut!

    al

    Leave a comment:

  • lepage
    Junior Member

  • lepage
    replied
    Bon, j'ai trouver que lors de l'installation l'insersion des données dans les tables ne se fait par complètement. Il manque des enregistrements. Par exemple la table Topology devrait avoir 80 enregistrements mais il y en a que 4. Ainsi de suite pour les autres tables.

    Une idée du problème?

    Merci,

    al

    Leave a comment:

  • lepage
    Junior Member

  • lepage
    replied
    Oui, >4.

    Ça logue et délogue mais j'ai seulement accès à la doc.

    Rien d'autre de dispo.

    Merci,

    al

    Leave a comment:


  • WAtt
    replied
    Pendant l'install, tu as bien fait attention a la version du Mysql ?

    (je cherche une autre possibilité)

    Leave a comment:

  • lepage
    Junior Member

  • lepage
    started a topic Vous n'êtes pas .... + DB_Error

    Vous n'êtes pas .... + DB_Error

    Salut,

    Nagios 2.9
    Oreon 1.4 + patch 1 à 5
    Fedora core 5

    A la suite d'une install sans problème, lorsque je tente de me loguer à la page d'entrée j'ai le message en rouge suivant;

    Vous n'êtes pas autorisé à accéder à cette page
    De plus j'ai la DB Error suivante en haut de la page web;

    DB Error WHERE Updating Session : UPDATE `session` SET `current_page` = '',`last_reload` = '1178736559', `ip_address` = '111.222.333.444' WHERE CONVERT( `session_id` USING utf8 ) = '80ad731afb1b2fe652bc6087f8121f31' AND `user_id` = '1' LIMIT 1 [nativecode=1264 ** Out of range value adjusted for column 'current_page' at row 2]
    J'utilise bien le userID/passWd que j'ai donné lors de la config. J'ai refait l'install 3 fois avec des UserID différents et même problème.

    Ne semble pas avoir de thread la dessus dans Wiki ni le forum.

    Vous avez une idée?

    Cordialement,

    al
Working...
X