Announcement

Collapse
No announcement yet.

Problème avec la notification

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problème avec la notification

    Bonjour,

    Il y a quelque chose que je ne comprends pas. J'ai configuré le service-generic pour notifier le groupe Admins sur toutes les alertes. Dans le groupe Admins, il y a un utilisateur administrateur avec mon adresse mail. La commande de notification est correctement configuré et pourtant je ne recois aucun mail.

    J'ai fait des tests d'envoie de mail en local (via /usr/bin/mail) et cela fonctionne très bien. La periode est fixé en 24x7 ... donc je ne vois vraiment pas ce qui bloque.

    Info complémentaire : le maileur local est postfix, lorsque je regarde le syslog j'ai des mails qui parte à destination de <[email protected]>. Est-ce bien normal ?

    Merci de votre aide,
    Kinai

  • #2
    Bonjour,
    Pourrais tu nous fournir en quote une extrait de ta configuration de nagios pour la notification par e-mail, ainsi que ton "service-generic" et le "contact_group" ici dans ton cas la definition du groupe Admins.

    Avec ces informations complémentaires, il serait surment plus facil de résoudre ton problème.
    Ubuntu 7.04
    nagios 2.8
    nagios-plugins 1.4.7
    ntop

    Comment


    • #3
      regarde ici sur le dernier post peut etre que ...
      http://forum.oreon-project.org/showthread.php?t=3419

      Comment


      • #4
        define contact{
        contact_name root
        alias Root
        contactgroups admins
        host_notification_period 24x7
        service_notification_period 24x7
        host_notification_options d,r
        service_notification_options w,u,c,r
        host_notification_commands host-notify-by-email
        service_notification_commands notify-by-email
        email [email protected]
        }

        define contactgroup{
        contactgroup_name admins
        alias Nagios Administrators
        members Administrateur, root
        }

        define service{
        name generic-service
        service_description generic-service
        is_volatile 0
        max_check_attempts 4
        normal_check_interval 0
        retry_check_interval 1
        active_checks_enabled 1
        passive_checks_enabled 1
        check_period 24x7
        parallelize_check 1
        obsess_over_service 1
        check_freshness 0
        event_handler_enabled 1
        flap_detection_enabled 1
        process_perf_data 1
        retain_status_information 1
        retain_nonstatus_information 1
        notification_interval 1
        notification_period 24x7
        notification_options w,u,c,r,f
        notifications_enabled 1
        contact_groups admins
        register 0
        }
        Merci pour votre aide (j'avais déjà vu ce post et j'ai enlevé le none qui y était, mais toujours pas de mail d'alerte)

        Kinaï

        Comment


        • #5
          regarde le nombre d'essai, si il est trop elever il va falloir attendre longtemps
          temps que le nombres d'essais n'est pas ecouler, le mail ne sera pas envoyer.
          As tu test avec l'utilisateur nagios d'envoyer un mail n'importe ou pour voir si il part?

          Comment


          • #6
            Oui, j'ai essayé en ligne de commande et ca fonctionne très bien.
            Concernant le nombre d'essais, j'ai mis une capture d'écran en attachement.
            Attached Files

            Comment


            • #7
              bonjour,

              2 verifs à faire:

              1. le chemin du mailer dans Oreon > Options > Oreon > Options Générales > Nagios

              2. la config du postfix dans /etc/postfix/main.cf

              particulierement relayhost = [MX.noname.com] (le serveur SMTP entre crochets)

              Code:
              smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
              myhostname = NAGIO1
              mydomain = toto.fr
              myorigin = $mydomain
              mydestination = $myhostname, localhost, $myhostname.$mydomain, localhost.$mydomain
              relayhost = [smtp.toto.fr]
              mynetworks = 127.0.0.0/8
              inet_interfaces = all

              Comment


              • #8
                J'ai résolu mon problème. J'avais préciser 0 au niveau de la notification dans le service ....

                Merci pour votre aide,
                kinai

                Comment


                • #9
                  l'ordonnacement regulier a 0 va aussi poser probleme je pense ...
                  A voir

                  Comment

                  Working...
                  X