Announcement

Collapse
No announcement yet.

Pear installation

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Pear installation

    bonjour

    Je suis actuellemnt en pleine installation des dependances pear "etapes 5 de l'installtion d'oreon".

    j'essaie d'installer cela :

    pear install -o -f --alldeps DB_DataObject DB_DataObject_FormBuilder MDB2 Date Numbers_Roman Numbers_Words HTML_Common HTML_QuickForm HTML_QuickForm_advmultiselect HTML_Table Auth_SASL Image_Canvas Image_Color Image_Graph Image_GraphViz Mail_Mime Net_Traceroute Net_Ping Validate

    mais voici mon message d'erreur :

    PEAR_Remote: :call: fsockopen('pear.php.net',80) failed

    Pourriez vous m'aider?

    merci de vos reponses!!!

  • #2
    Tiens j'avais eu le meme problème. On en a parlé ici En espérant que ca résolura ton preoblème ;-)

    Comment


    • #3
      il faut avoir accès à internet
      Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
      Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
      Fedora Core 5 - 2.6.20-1.2320

      Comment


      • #4
        Dans mon cas à moi c'est que j'avais acces à internet mais je passais par un proxy, mais meme en faisant export http_proxy="..." bah ca voulais pas :? J'ai dut donc prendre une ip fixe et me connecter idrectement à internet sans proxy.

        Comment


        • #5
          Ca est, ca venait bien du proxy

          Maintenant, j'ai un autre probleme, lorsque j'installer des differentes dependances de pear, il le telechargent mais ne les installe pas car il manque le package.xml

          Voici le message :

          No handlers for package.xml version 2.0

          Merci a vous!!!

          Comment


          • #6
            Tu peux pas le télécharger ce package ? Sois en ligne de commande ou soit sur le net si tu trouves et ensuite tu installes tes dep :roll:

            Comment


            • #7
              sisi, j'ai essayer mais cela ne fonctionne pas...

              je trouve pas le bon package

              Comment


              • #8
                Essaye ca pour PEAR :
                Code:
                -- Installation des composants de PEAR :
                # pear channel-update pear.php.net
                # pear install XML_RPC
                # pear update-channels
                # pear install -ofa DB DB_DataObject DB_DataObject_FormBuilder MDB2 Date Numbers_Roman
                Numbers_Words HTML_Common HTML_QuickForm HTML_QuickForm_advmultiselect HTML_Table
                Archive_Tar Auth_SASL Console_Getopt HTTP Image_Canvas Image_Color Image_Graph
                Image_GraphViz Mail Mail_Mime Net_SMTP Net_Socket Net_Traceroute Net_Ping Validate
                XML_RPC
                Pour etre sur que tout soit à la dernière version :
                # pear upgrade-all
                Cela vient du tuto de Arkhan

                Comment


                • #9
                  merci pour le tuto!!!

                  mais ce n'est pas exactement mon probleme...

                  de plus, la commande "#pear channel-update pear.php.net" ne fonctionne pas. il me dis que "pear.php.net" n'est pas valide.

                  Sais tu ce qu'est le "package.xml" version 2.0 qui me manque pour continuer mon installe.

                  Merci beaucoup!!!

                  Comment


                  • #10
                    Aucune idée dsl :?

                    Comment


                    • #11
                      j'ai telecharger pear 1.6 et mis a jour, donc maintenant, je n'est plus ce probleme de "package.xml version 2.0" et apparement, les dependances PEAR ont l'air de s'installer

                      EX:

                      #pear install -o -f --alldeps DB_DataObject

                      warning: pear/DB_Object requires packages "pear/DB" (version >=1.7.0), installed version is 1.6.2
                      Downloding DB_DataObject-1.8.5.tgz...
                      Starting to downlaod DB........
                      ......... done: 61,135 bytes
                      install ok: channel://pear.php.net/DB_DataObject-1.8.5


                      Mais lorsque je fais un pear list-upgrades, les packages soit disant installés n'apparaissent pas dans la liste.
                      De meme qu'il reste en "failed" dans l'etape 5 "Verifying PHP Pear Component" de l'installtion d'oreon.

                      Que faire?

                      Merci de vos reponses...

                      Comment


                      • #12
                        pear upgrade-all pour mettre tout à jour comme ca ca mettra tes packs pear à jour et après tu relances toute l'installe voir si cette fois ils s'installent bien. C'est une idée mais pas sur que ca marche ... :roll: je me demande meme si c'est pas inutile ... enfin qui tente rien n'a rien

                        Comment


                        • #13
                          j'ai effectuer l'upgrade mais il ne met a jour que les paquets deja installés mais pas ceux non installés

                          Comment

                          Working...
                          X