Announcement

Collapse
No announcement yet.

Pas de monitoring

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts
    rom
    Centreoniste

  • rom
    replied
    Oui il faut enlever cette ligne, sinon cela ne fonctionne pas.

    L'option de lecture rapide des logs correspond en fait a un besoin de "tailler" le fichier de log de Nagios en supprimant l'indentation inutile (retour chariot..) qui le rende assez imposant. C'est un cron qui a interval regulier va retravailler le fichier pour une lecture plus rapide.

    Son utilisation ne concerne generalement que ceux qui ont plusieurs milliers d'elements dans leur monitoring, couplé a un raffraichissement assez courts...

    Quand on aura les logs en base de données (Ndo stable), on sera bcp plus performant dans le monitoring temps reel...

    Leave a comment:

  • Gio
    Junior Member

  • Gio
    replied
    Originally posted by dlaperle View Post
    Sous Fedora Core6 pour que le restart via l'interface fonctionne tu dois faire ceci:
    Code:
    nano /etc/sudoers
    Tu trouves requiretty = true et tu commentes cette ligne (ajoute # devant) et après tu pourras redémarrer via OREON!
    Je n'ai pas trouvé cette ligne, par contre j'avais la ligne
    Code:
    ...
    Defaults      requiretty
    ...
    Je l'ai commentée et ça à l'air de fonctionner.

    Leave a comment:

  • ck1caribou
    Junior Member

  • ck1caribou
    replied
    Originally posted by Gio View Post
    Je ne sais pas si cela s'applique à ta configuration mais j'ai eu le même problème et je l'ai résolu de la façon suivante :

    'Options -> Options Générales -> OreonDataStorage'
    Partie 'Monitoring' décocher 'Lecture rapide des status'

    J'espère que cela résoudra ton problème.
    Et bien merci ca marche egalement pour moi.
    Quelqu'un sait d'ou viens le probleme (bug, element manquant...???)

    Leave a comment:

  • dlaperle
    Junior Member

  • dlaperle
    replied
    Sous Fedora Core6 pour que le restart via l'interface fonctionne tu dois faire ceci:

    Code:
    nano /etc/sudoers
    Tu trouve requiretty = true

    et tu commente cette ligne (ajoute # devant)

    et après tu pourras redémarrer via OREON!

    Leave a comment:

  • Gio
    Junior Member

  • Gio
    replied
    Oui je fait bien ce que tu dis par contre Nagios ne se relance pas pour moi de cette façon.
    Je me suis donc fait un script bash pour relancer automatiquement les services à chaques fois.

    Sinon cette commande te suffira je pense :
    /etc/rc.d/init.d/nagios restart

    Leave a comment:

  • Sir
    Senior Member

  • Sir
    replied
    Tu relances bien ton service nagios sous Oreon via :

    Configuration > Nagios (mettre déplacer les fichier à 'Oui', Recharger à 'Oui)

    ???

    Leave a comment:

  • Gio
    Junior Member

  • Gio
    replied
    Je ne sais pas si cela s'applique à ta configuration mais j'ai eu le même problème et je l'ai résolu de la façon suivante :

    'Options -> Options Générales -> OreonDataStorage'
    Partie 'Monitoring' décocher 'Lecture rapide des status'

    J'espère que cela résoudra ton problème.

    Leave a comment:

  • ck1caribou
    Junior Member

  • ck1caribou
    started a topic Pas de monitoring

    Pas de monitoring

    Bonjour,
    j'ai installe nagios 2.7 sur fedora core 6 via le rpm et configure l'interface graphique par defaut. Ca fonctionne mais c'est tres laid, j'ai donc decide d essayer oreon.
    J'ai suivi le guide d'installation en adaptant les differents parametres selon ma configuration de base. Malheureusement j'ai bien une jolie interface mais elle est vide de contenu.
    J'ai recree une config de base avec hotes, service, etc... Celle ci se charge via la page de configuration, nagios est redemarrer comme prevu mais je n'ai toujours aucun contenu dans le monitoring oreon (hote = 0, service = 0 ...) alors que le reporting lui fonctionne.

    Pour info l'interface graphique de base de nagios m'affiche bien cette nouvelle config.

    Apres avoir reverifier 15 fois les droits, chemins des differents fichiers et repertoires je me tourne vers vous pour solutionner ce probleme.

    Merci.
Working...
X