Announcement

Collapse
No announcement yet.

[REGLE] Install PEAR : plantage

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • lowdata
    replied
    Exact j'ai modifié memory_limit, plus d'autres soucis de dependances de paquets Pear, tout est OK now Merci p.

    Leave a comment:


  • MaEsTrO
    replied
    Si tu donnes plus de RAM à php dans php.ini (genre 32), il raconte quoi ?

    Leave a comment:


  • rem
    replied
    Bonjour,

    Pour ton 1er probleme (résolu apparament), tu peux configurer le proxy sous pear. Je sais pas si tu l'a fait mais je vais donner la commande ca peut toujours servir à d'autres !
    pear config-set http_proxy http://login:[email protected]_proxy:Port

    Pour ton 2 eme problème je vois pas de solution ! dsl ! mais essaye d'utiliser pear directement (en ayant réglé le proxy).

    Bon courage !

    Leave a comment:


  • Sir
    replied
    Moi j'ai jamais eu ce problème, et comme j'ai pas une grande expérience de Linux, je séche là.

    Leave a comment:


  • lowdata
    replied
    Pwa...

    Merci des conseils Sir. Donc oui c'est le proxy qui bloque, je viens de download tout les plugins necessaires...et au moment d'installer je me prends ca :

    Code:
    exp:~/Desktop/pear # pear5 install Auth_SASL-1.0.2.tgz
    PHP Fatal error:  Allowed memory size of 8388608 bytes exhausted (tried to allocate 85 bytes) in /usr/share/php5/PEAR/PEAR/Registry.php on line 1006
    Allowed memory size of 8388608 bytes exhausted (tried to allocate 23 bytes)
    exp:~/Desktop/pear # pear5 install DB-1.7.12.tgz
    PHP Fatal error:  Allowed memory size of 8388608 bytes exhausted (tried to allocate 92160 bytes) in /usr/share/php5/PEAR/PEAR/Dependency2.php on line 416
    exp:~/Desktop/pear # pear5 install Date-1.4.7.tgz
    PHP Fatal error:  Allowed memory size of 8388608 bytes exhausted (tried to allocate 70174 bytes) in /usr/share/php5/PEAR/PEAR/Task/Replace.php on line 177
    Nikel. A priori c'est un soucis de memoire, j'ai deja modif au cas la valeur memory_size dans php.ini a 16M, mais ca a pas l'air de venir de ca.... une idée ? merci d'avance.

    Leave a comment:


  • Sir
    replied
    Oui, il y a de forte chance que ce soit le proxy de boite qui empêche le téléchargement des fichiers (tu peux pingué google ? jette un coup d'oeil sur google à la commande EXPORT HTTP_PROXY)

    Pour ce quiest de Nagios2, mais pour moi, c'est un peu comme poser la question de savoir pourquoi de savoir si il y a un interet de passer à la suse 10 alors que la 9 fonctionne bien . Y'a toujours des choses en plus et comme Oreron est 100% copatible avec Nagios2, si à la base tu pars de rien, autant prendre nagios2. Par contre, si tu as déja une configuration qui tourne et que tu connait bien sous nagios1, c'est une autre histoire.

    Leave a comment:


  • lowdata
    replied
    ok, et serait ce possible que ce soit le Proxy de ma boite qui bloque l'acces aux fichier a l extension .tar etc... et du coup qui empechent d'install ces composants ?

    Pour la doc c'est good j'ai pris celle de aprentilinux & co ca devrait aller.. p

    ps: Y'a un reel interet a posseder la version 2 de Nagios ou rester avc la 1 combiné a Oreon ne pose aussi aucun probleme ?

    Leave a comment:


  • Sir
    replied
    Donc, tous ces fichiers sont nécessaires a Oréon. Normalement quand tu tapes la commande indiqué, cela va cherche les paquets manquants sur le site ou il sont stockés. Mais pourque cela marche, il faut que le serveur sur lequel tu installe Oreon est une connexion internet. Si ce n'est pas le cas, tu dois aller sur le site http://pear.php.net/packages.php, télecharger les paquets et les installer à la main (et c'est chiant et long, je suis passer par là aussi)

    P.S : Si c'est ta première installation d'Oreon/Centreon, y'a des tutos qui peuvent t'expliquer surement mieux que moi sur le wiki.

    Leave a comment:


  • lowdata
    replied
    Bonjour Sir,

    Je suis sur Suse 10, et en effet j'ai bien installé php5-pear, je viens de voir que quand je faisais un

    pear5 install -o -f --alldeps DB DB_DataObject DB_DataObject_FormBuilder MDB2 Date Numbers_Roman Numbers_Words HTML_Common HTML_QuickForm HTML_QuickForm_advmultiselect HTML_Table Auth_SASL HTTP Image_Canvas Image_Color Image_Graph Image_GraphViz Ma etc..
    Il me sortait ca erreur :
    No releases available for package "pear.php.net/DB"
    Cannot initialize 'DB', invalid or missing package file
    No releases available for package "pecl.php.net/DB_DataObject"
    Cannot initialize 'DB_DataObject', invalid or missing package file
    No releases available for package "pecl.php.net/DB_DataObject_FormBuilder"
    Cannot initialize 'DB_DataObject_FormBuilder', invalid or missing package file
    No releases available for package "pecl.php.net/MDB2"
    Cannot initialize 'MDB2', invalid or missing package file
    No releases available for package "pecl.php.net/Date"
    Cannot initialize 'Date', invalid or missing package file
    No releases available for package "pecl.php.net/Numbers_Roman"
    Cannot initialize 'Numbers_Roman', invalid or missing package file
    No releases available for package "pecl.php.net/Numbers_Words"
    Cannot initialize 'Numbers_Words', invalid or missing package file
    No releases available for package "pecl.php.net/HTML_Common"
    Cannot initialize 'HTML_Common', invalid or missing package file
    No releases available for package "pecl.php.net/HTML_QuickForm"
    Cannot initialize 'HTML_QuickForm', invalid or missing package file
    No releases available for package "pecl.php.net/HTML_QuickForm_advmultiselect"
    Cannot initialize 'HTML_QuickForm_advmultiselect', invalid or missing package file
    No releases available for package "pecl.php.net/HTML_Table"
    Cannot initialize 'HTML_Table', invalid or missing package file
    No releases available for package "pecl.php.net/Auth_SASL"
    Cannot initialize 'Auth_SASL', invalid or missing package file
    No releases available for package "pecl.php.net/HTTP"
    Cannot initialize 'HTTP', invalid or missing package file
    No releases available for package "pecl.php.net/Image_Canvas"
    Cannot initialize 'Image_Canvas', invalid or missing package file
    No releases available for package "pecl.php.net/Image_Color"
    Cannot initialize 'Image_Color', invalid or missing package file
    No releases available for package "pecl.php.net/Image_Graph"
    Cannot initialize 'Image_Graph', invalid or missing package file
    No releases available for package "pecl.php.net/Image_GraphViz"
    Cannot initialize 'Image_GraphViz', invalid or missing package file
    No releases available for package "pecl.php.net/Mail"
    Cannot initialize 'Mail', invalid or missing package file
    No releases available for package "pecl.php.net/Mail_Mime"
    Cannot initialize 'Mail_Mime', invalid or missing package file
    No releases available for package "pecl.php.net/Net_SMTP"
    Cannot initialize 'Net_SMTP', invalid or missing package file
    No releases available for package "pecl.php.net/Net_Socket"
    Cannot initialize 'Net_Socket', invalid or missing package file
    No releases available for package "pecl.php.net/Net_Traceroute"
    Cannot initialize 'Net_Traceroute', invalid or missing package file
    No releases available for package "pecl.php.net/Net_Ping"
    Cannot initialize 'Net_Ping', invalid or missing package file
    No releases available for package "pecl.php.net/Validate"
    Cannot initialize 'Validate', invalid or missing package file
    No releases available for package "pecl.php.net/XML_RPC"
    Cannot initialize 'XML_RPC', invalid or missing package file
    No releases available for package "pecl.php.net/SOAP"
    Cannot initialize 'SOAP', invalid or missing package file
    Package "DB" is not valid
    Package "DB_DataObject" is not valid
    Package "DB_DataObject_FormBuilder" is not valid
    Package "MDB2" is not valid
    Package "Date" is not valid
    Package "Numbers_Roman" is not valid
    Package "Numbers_Words" is not valid
    Package "HTML_Common" is not valid
    Package "HTML_QuickForm" is not valid
    Package "HTML_QuickForm_advmultiselect" is not valid
    Package "HTML_Table" is not valid
    Package "Auth_SASL" is not valid
    Package "HTTP" is not valid
    Package "Image_Canvas" is not valid
    Package "Image_Color" is not valid
    Package "Image_Graph" is not valid
    Package "Image_GraphViz" is not valid
    Package "Mail" is not valid
    Package "Mail_Mime" is not valid
    Package "Net_SMTP" is not valid
    Package "Net_Socket" is not valid
    Package "Net_Traceroute" is not valid
    Package "Net_Ping" is not valid
    Package "Validate" is not valid
    Package "XML_RPC" is not valid
    Package "SOAP" is not valid
    install failed
    La je vois aps du tout ce qui cloche Auriez vous une idée ?

    Leave a comment:


  • Sir
    replied
    C'est ta première installation d'Oreon/Centreon ?

    Tu a bien le paquet php-pear ?

    Leave a comment:


  • lowdata
    started a topic [REGLE] Install PEAR : plantage

    [REGLE] Install PEAR : plantage

    Lu all.

    Voila je suis en train d'install Oreon (enfin centreon), je rencontre un soucis à l'etape 5....

    arrivé a l etape 4 une fois quej 'ai renseigné le chemin de PEAR, ca me mets bien OK partout pour l'etape 4. Je valide, et arrivé aux extensions PEAR, TOUT est en mode FAILED.

    Je vais en console pour tester PEAR,et la :
    Code:
    PEAR : command not found !
    Alors que j'ai bien mis le bon path lors de l'install d Oreon, et que a l etape4 il me dit OK....Sauriez vous ce qui ne vas pas ? Comment faire pour qu'il reconnaisse PEAR c'est vraiment etrange.

    Merci d'avance de votre aide.
Working...
X