Announcement

Collapse
No announcement yet.

update Centreon1.4.1-RC1 problème

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • fan
    replied
    ouf soulagement

    J'ai ajouté : include_path="/usr/share/pear" dans le php.ini puis restart httpd et c'est passé !
    Mais bon, ca m'inquiete quand même que quand j'ai fais un "back", il m'est mis update de la base de données : CRITIQUE

    Leave a comment:


  • fan
    replied
    Je suis en train de devenir fou, je redoutais cet udpate mais alors là çà commence à être un peu la panique...

    Maintenant quand je fais un "back", j'obtiens :
    Code:
    Component	Status
    Database ’oreon’ : Upgrade	CRITICAL
    
    Duplicate column name 'traps_status'
    Duplicate column name 'manufacturer_id'
    Duplicate column name 'description'
    Can't DROP 'perfparse_installed'; check that column/key exists
    Duplicate column name 'patch_type_stable'
    Duplicate column name 'patch_type_RC'
    Duplicate column name 'patch_type_patch'
    Duplicate column name 'patch_type_secu'
    Duplicate column name 'patch_type_beta'
    Duplicate column name 'patch_url_service'
    Duplicate column name 'patch_url_download'
    Duplicate column name 'patch_path_download'
    Can't DROP 'snmp_trapd_used'; check that column/key exists
    Duplicate column name 'event_broker_options'
    Table 'traps_vendor' already exists
    Duplicate entry '1' for key 1
    Can't create table './oreon/#sql-10ff_cd547.frm' (errno: 121)
    Duplicate column name 'perl_library_path'
    Can't DROP 'traps_handler'; check that column/key exists
    Comment ai je pu passer à l'étape suivante si le statut d'upgrade de la base de données est à critique...?

    Une âme généreuse pour m'apporter un peu de soutien ?

    Merci
    Last edited by fan; 30 July 2007, 15:31.

    Leave a comment:


  • fan
    replied
    Merci

    Code:
    [[email protected] centreon-1.4.1-RC1]# pear list
    Installed packages, channel pear.php.net:
    =========================================
    Package                       Version  State
    Archive_Tar                   1.3.2    stable
    Auth_SASL                     1.0.2    stable
    Console_Getopt                1.2.3    stable
    DB                            1.7.12   stable
    DB_DataObject                 1.8.7    stable
    DB_DataObject_FormBuilder     1.0.0RC7 beta
    Date                          1.4.7    stable
    HTML_Common                   1.2.4    stable
    HTML_QuickForm                3.2.9    stable
    HTML_QuickForm_ElementGrid    0.1.1    alpha
    HTML_QuickForm_advmultiselect 1.4.0    stable
    HTML_Table                    1.8.1    stable
    HTTP                          1.4.0    stable
    HTTP_Request                  1.4.1    stable
    Image_Canvas                  0.3.1    alpha
    Image_Color                   1.0.2    stable
    Image_Graph                   0.7.2    alpha
    Image_GraphViz                1.2.1    stable
    MDB2                          2.4.1    stable
    Mail                          1.1.14   stable
    Mail_Mime                     1.5.2    stable
    Mail_mimeDecode               1.5.0    stable
    Net_DIME                      0.3      beta
    Net_Ping                      2.4.2    stable
    Net_SMTP                      1.2.10   stable
    Net_Socket                    1.0.8    stable
    Net_Traceroute                0.21.1   alpha
    Net_URL                       1.0.15   stable
    Numbers_Roman                 0.2.0    stable
    Numbers_Words                 0.15.0   beta
    PEAR                          1.6.1    stable
    SOAP                          0.11.0   beta
    Structures_Graph              1.0.2    stable
    Validate                      0.7.0    beta
    XML_RPC                       1.5.1    stable
    [[email protected] centreon-1.4.1-RC1]#
    Comment se fait il que je n'arrive pas à passer à l'etape suivante de l'installation. Quand je fais un "recheck" de mes composants php, tout reste en "failed"...

    Leave a comment:


  • stan314
    replied
    Pour savoir ce qui est installé il faut faire :

    Code:
    pear list
    et la ca va t'affiché ce que tu as installer avec pear...

    @+
    stan

    Leave a comment:


  • fan
    started a topic update Centreon1.4.1-RC1 problème

    update Centreon1.4.1-RC1 problème

    Bonjour à vous.

    Bon je suis la procédure wiki. J'ai lancé le script install.sh et ai répondu aux questions.
    Je vais sur l'interface web pour compl"ter l'install.
    Arrivé à la page "Verifying PHP Pear Component", tout est en failed ! Je tape alors la commande indiquée pour installer tout ce qu'il faut mais il ne m'installe pas les versions voulus, il m'installe les dernière.

    Du coup, je ne peux pas terminer mon install !

    Code:
    Run this shell command under root user :
    pear install -o -f --alldeps DB DB_DataObject DB_DataObject_FormBuilder MDB2 Date Numbers_Roman Numbers_Words HTML_Common HTML_QuickForm HTML_QuickForm_advmultiselect HTML_Table Archive_Tar Auth_SASL Console_Getopt HTTP Image_Canvas Image_Color Image_Graph Image_GraphViz Mail Mail_Mime Net_SMTP Net_Socket Net_Traceroute Net_Ping Validate XML_RPC SOAP
    Je tape cette commande donc et j'obtiens :

    Code:
    WARNING: "pear/DB" is deprecated in favor of "pear/MDB2"
    WARNING: failed to download pear.php.net/DB_DataObject_FormBuilder within preferred state "stable", will instead download version 1.0.0RC7, stability "beta"
    WARNING: failed to download pear.php.net/Numbers_Words within preferred state "stable", will instead download version 0.15.0, stability "beta"
    WARNING: failed to download pear.php.net/Image_Canvas within preferred state "stable", will instead download version 0.3.1, stability "alpha"
    WARNING: failed to download pear.php.net/Image_Graph within preferred state "stable", will instead download version 0.7.2, stability "alpha"
    WARNING: failed to download pear.php.net/Net_Traceroute within preferred state "stable", will instead download version 0.21.1, stability "alpha"
    WARNING: failed to download pear.php.net/Validate within preferred state "stable", will instead download version 0.7.0, stability "beta"
    WARNING: failed to download pear.php.net/SOAP within preferred state "stable", will instead download version 0.11.0, stability "beta"
    WARNING: failed to download pear.php.net/HTML_QuickForm_ElementGrid within preferred state "stable", will instead download version 0.1.1, stability "alpha"
    WARNING: failed to download pear.php.net/Net_DIME within preferred state "stable", will instead download version 0.3, stability "beta"
    warning: pear/HTML_Table requires PEAR Installer (version >= 1.5.0), installed version is 1.4.9
    warning: pear/pear dependency package "pear/Archive_Tar" installed version 1.3.2 is not the recommended version 1.3.1
    warning: pear/Mail_Mime requires PEAR Installer (version >= 1.6.0), installed version is 1.4.9
    Apres celà, il m'installe tous les composants indiquées.

    Mais quand je tape ce qui suit, il devrait me retourner les packages installés non ??

    Code:
    [[email protected] centreon-1.4.1-RC1]# pear list-upgrades
    pear.php.net Available Upgrades (stable):
    =========================================
    Channel      Package Local          Remote         Size
    pear.php.net PEAR    1.4.9 (stable) 1.6.1 (stable) 289kB

    Merci de votre aide
    Last edited by fan; 30 July 2007, 15:19.
Working...
X