Announcement

Collapse
No announcement yet.

PHP Pear Extension versions

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • PHP Pear Extension versions

    I'm trying to do a new install (centreon-1.4.1-RC3).

    All deps installed.

    PHP pear installed (pear install -o -f --alldeps ...).

    Setup step 5 ask about the php pear versions:

    DB Failed Need DB-1.7.6
    DB_DataObject Failed Need DB_DataObject-1.8.4
    DB_DataObject_FormBuilder Failed Need DB_DataObject_FormBuilder-1.0.0RC4
    Date Failed Need Date-1.4.6

    and others ...

    Installed versions:

    DB 1.7.12 stable
    DB_DataObject 1.8.7 stable
    DB_DataObject_FormBuilder 1.0.0RC7 beta
    Date 1.4.7 stable

  • #2
    I had the same issue, you will need to install the specific version of the PEAR extension.

    For example:

    pear install -f --alldeps DB-1.7.6

    It appears that the exact versions are needed for some parts.

    Hope that helps.

    Comment


    • #3
      Thanks for help.

      Comment


      • #4
        you should first upgrade PEAR :
        # pear upgrade PEAR

        And then launch the command line specify in step 5, with the missing package.
        Romain Le Merlus
        Centreon Forge
        MERETHIS

        Comment

        Working...
        X