Announcement

Collapse
No announcement yet.

Probleme de graph avec centreon 1.4.1

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Probleme de graph avec centreon 1.4.1

    bonjour

    j'ai installer centreon 1.4.1 sur une debian 3.1 (installation a partir de zero)
    avec nagios 2.9 et j'ai activer ods
    Quand je vais voir mes graph j'ai une croix rouge qui s'affiche

    Que faire (est ce que j'ai oublier quelque chose) sachant que les service que j'ai parametrer sont check_centreon_ping et check_centreon_process

    dans var/lib/ods/database/ j'ai bien des fichiers *.rrd

    Merci d'avance
    debian 4.0 Nagios 2.9 Plugins 1.4.8

  • #2
    Moi aussi, je galère depuis 2j pour activer ces graphes..

    J'ai parcouru tous les sujets sur ce point, et je sèche. Dans mon cas, je ne parle pas des "anciens" plugins check_graph et tutti quanti, je parle des plugins ods qui utilisent les check_snmp fournis (ou ceux originaux, peu importe). J'ai bien des données de performance qui sont remontées et que je vois dans la description des hosts et des services dans oreon, mais pas moyen de les voir apparaitre dans la section vues oreon.

    visiblement l'ods ne parse pas le bon fichier, étrange...et pas moyen d'avoir une info dans un log :confused: :rolleyes:

    merci pour votre aide, en attendant je vais lancer le debug mode de perl, je vois pas quoi faire d'autre.

    pour info j'ai un nagios 2.9 et un centreon 1.4.1, tous les droits et chemins ont été vérifiés 15 fois..

    Merci!!!!!!

    Comment


    • #3
      bonsoir

      j'ai reussi a faire marcher centreon avec ods sur une debian 4.0

      par contre je n'est toujour pas reussi a le faire marche sur une debian 3.1

      je cherche encore pourquoi
      debian 4.0 Nagios 2.9 Plugins 1.4.8

      Comment


      • #4
        Bon j'ai pas mal progressé, déjà en activant l'option process performance data dans la description des services et/ou des hosts c'est beaucoup mieux :| Reste qu'il faudrait peut etre le préciser comme verif dans la doc.

        Petit truc aussi que j'ai trouvé, dans le plugin process-service-perfdata, il faut virer les " " pour la définition de PERFFILE -et ca aussi c'est pas indiqué dans la doc


        Bon maintenant que j'ai fini de raler , il me reste un soucis, cad que maintenant je vois bien que je peux faire des graphes mais rien ne s'affiche, et j'ai un message Argument "$" isn't a numeric line 78 à l'execution d'ods dans le perl script identifyMetric.pm

        Visiblement un pb de contenu de la variable, et je suis bien deg

        J'ai pas patché, mais je suis parti d'une version Centreon 1.4.1 donc a priori pas besoin? quoi qu'il en soit j'ai essayé et j'ai eu plein de rejets du coup j'ai fait un rollback.

        Votre aide serait très appréciée, je voulais faire une démo demain AM, dommage..
        Last edited by mr.mandrake74; 13 August 2007, 21:13.

        Comment


        • #5
          En fait, a priori j'ai pas de colonnes value dans la table metrics, je sais pas si c'est bien normal tout ca

          Champ Type Interclassement Attributs Null Défaut Extra Action
          metric_id int(11) Non auto_increment
          index_id int(11) Oui NULL
          metric_name varchar(32) latin1_swedish_ci Oui NULL
          unit_name varchar(32) latin1_swedish_ci Oui NULL
          warn float Oui NULL
          crit float Oui NULL

          Comment


          • #6
            Apparemment pas de colonne value dans table metric :

            CREATE TABLE `metrics` (
            `metric_id` int(11) NOT NULL auto_increment,
            `index_id` int(11) default NULL,
            `metric_name` varchar(32) default NULL,
            `unit_name` varchar(32) default NULL,
            `warn` float default NULL,
            `crit` float default NULL,
            PRIMARY KEY (`metric_id`),
            KEY `index` (`index_id`)
            ) ENGINE=MyISAM DEFAULT CHARSET=latin1;


            Moi je sèche sur ODS qui drop toutes mes données systématiquement en provenance du fichier service-perfdata.out

            Si quelqu'un a une idée ...

            Comment


            • #7
              Originally posted by mr.mandrake74 View Post
              En fait, a priori j'ai pas de colonnes value dans la table metrics, je sais pas si c'est bien normal tout ca

              Champ Type Interclassement Attributs Null Défaut Extra Action
              metric_id int(11) Non auto_increment
              index_id int(11) Oui NULL
              metric_name varchar(32) latin1_swedish_ci Oui NULL
              unit_name varchar(32) latin1_swedish_ci Oui NULL
              warn float Oui NULL
              crit float Oui NULL
              normal ca les "value" sont dans data_bin.
              Julien Mathis
              Centreon Project Leader
              www.merethis.com |

              Comment


              • #8
                Originally posted by bierryf View Post

                Moi je sèche sur ODS qui drop toutes mes données systématiquement en provenance du fichier service-perfdata.out

                Si quelqu'un a une idée ...
                il vient d'ou ce fichier ?
                Julien Mathis
                Centreon Project Leader
                www.merethis.com |

                Comment


                • #9
                  Bingo, les graphs commencent à apparaître
                  j'avais mal configuré la commande process-service-perfdata
                  j'ai plus qu'à repasser dans mes plugins pour intégrer le string récupéré par ods (et aussi à nettoyer ma conf pour que l'import/export à partir de centreon fonctionne)

                  Comment


                  • #10
                    Originally posted by julio View Post
                    il vient d'ou ce fichier ?
                    il vient de la sortie de la commande process-service-perfdata

                    Comment

                    Working...
                    X