Announcement

Collapse
No announcement yet.

Conf. network/réseau Nagios/Windows?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Conf. network/réseau Nagios/Windows?

    La version Francaise suit la version anglaise.

    Anglais :
    Hello, I have a network running on a few Windows Server 2003 machines. They're set into a domain, on the same network as Nagios/Centreon machine is. Even though Nagios isn't in the domain, it should be able to retrieve information about the Windows platform machines using the SNMP protocol, right?

    I have installed SNMP, configured it to be "PUBLIC" and given the right IP to let Nagios connect to it. Then went into Centreon, added the host but then it doesn't show the host being Active in the status bar.:confused: It's not even detected by Nagios (the Windows server isn't listed).

    What do I have to do?

    Thanks in advance.
    ------------------------------------

    French :
    Salut, j'ai un réseau composé de serveurs fonctionnant sous "Windows 2003 Server". Les serveurs sont dans un domaine, cependant la machine Nagios/Centreon n'est pas dans le domaine, seulement sur le réseau de celui-ci. Est-ce qu'il sera tout de même capable de communiquer avec les serveurs Windows sans problèmes en utilisant SNMP ?

    J'ai installé SNMP, l'ai configuré en étant "PUBLIC" et donné la bonne adresse IP pour que Nagios puisse se connecter. Ensuite dans Centreon, j'ai ajouté le hosts du serveur windows mais dans la barre de status, l'host ne s'affiche pas en tant qu'actif, même qu'il n'est pas détecté par Nagios.

    Que dois-je faire d'autre?
    Merci.

  • #2
    As-tu bien exporté la config de Centreon vers Nagios et as-tu redémarré Nagios?

    Comment


    • #3
      Originally posted by Dellrak View Post
      As-tu bien exporté la config de Centreon vers Nagios et as-tu redémarré Nagios?
      Je dois aller "Config/Nagios/Exporter" et appuyer sur "Générer" afin d'exporté la config de Centreon vers Nagios? Si oui, que dois-je cocher exactement?
      -v = oui
      -s = oui
      Déplacer les fichiers = non ?
      Recharger Nagios = oui ? et restart ou reload?

      Merci, je vais tester ça.
      Last edited by bad_acid; 19 August 2007, 19:57.

      Comment


      • #4
        Mon host est configuré, je lui ai mis un service (check hdd space), et puis fait un export, rebooter complètement la machine pour être certain (debian), et toujours rien de fonctionnel coté host.

        Il m'indique encore Critical = 1 dans le status bar.

        J'ai pris la VM de "smarechal", donc le critical, c'est sans doute son host "test" qui est encore présent. Je n'arrive pas à comprendre pourquoi c'est encore afficher alors que je l'ai pourtant supprimer des hosts y compris son service.

        Comment


        • #5
          Certainement parce que Nagios ne s'est pas redémarré. J'ai déjà eu le problème sur centOS, le script d'arret/redémarrage de nagios est buggué.

          Vérifie bien que tes fichiers ont bien été copiés dans le répertoir de config de nagios (un petit grep pour vérifier que le host test a bien été viré), et arrete/redémmare ton nagios 'à la main'.

          Good luck
          MdK

          Comment

          Working...
          X