Announcement

Collapse
No announcement yet.

Installation impossible :Version des composants PHP Pear incorrecte

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Installation impossible :Version des composants PHP Pear incorrecte

    Bonjour,
    je viens d'installer sans problème Nagios 2.9 sur une Debian en suivant le tuto présent sur le wiki.
    J'essaie maintenant d'installer Centreon, mais lorsque sur http://@ipserveur/oreon/, j'arrive à la page 5 (Verifying PHP Pear Component),
    pour chacun des composants j'ai
    DB Failed
    Need DB-1.7.6
    DB_DataObject Failed
    Need DB_DataObject-1.8.4
    DB_DataObject_FormBuilder Failed
    Need DB_DataObject_FormBuilder-1.0.0RC4
    MDB2 Failed
    ...etc...

    alors que j'avais deja installé tout le nécessaire.
    En bas de page, il y a marqué:
    Run this shell command under root user :
    pear install -o -f --alldeps DB DB_DataObject DB_DataObject_FormBuilder MDB2 Date Numbers_Roman Numbers_Words HTML_Common HTML_QuickForm HTML_QuickForm_advmultiselect HTML_Table Archive_Tar Auth_SASL Console_Getopt HTTP Image_Canvas Image_Color Image_Graph Image_GraphViz Mail Mail_Mime Net_SMTP Net_Socket Net_Traceroute Net_Ping Validate XML_RPC SOAP

    Je lance alors cette commande et l'installation des différents composants se fait, mais je remarque que les versions installées sont différentes de celles requises, et j'ai aussi des warning tels que :

    WARNING: "pear/DB" is deprecated in favor of "pear/MDB2"
    WARNING: failed to download pear.php.net/DB_DataObject_FormBuilder within preferred state "stable", will instead download version 1.0.0RC7, stability "beta"
    WARNING: failed to download pear.php.net/Numbers_Words within preferred state "stable", will instead download version 0.15.0, stability "beta"
    WARNING: "pear/HTML_Common" is deprecated in favor of "pear/HTML_Common2"
    WARNING: "pear/HTML_QuickForm" is deprecated in favor of "pear/HTML_QuickForm2"
    WARNING: failed to download pear.php.net/Image_Canvas within preferred state "stable", will instead download version 0.3.1, stability "alpha"
    WARNING: failed to download pear.php.net/Image_Graph within preferred state "stable", will instead download version 0.7.2, stability "alpha"

    Est ce a cause des versions installées que l'installation n'aboutit pas ?
    Merci de vos réponses!

  • #2
    Ta machine a accès à internet ?
    Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
    Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
    Fedora Core 5 - 2.6.20-1.2320

    Comment


    • #3
      J'ai trouvé mon erreur.
      En fait, j'avais mal renseigné le champ Where is PEAR Path ? sur le setup.sh, donc il ne trouvait pas les composants .

      Comment


      • #4
        J'ai la meme erreur que toi, j'ai également lancé la commande :
        pear install -o -f --alldeps DB DB_DataObject DB_DataObject_FormBuilder MDB2 Date Numbers_Roman Numbers_Words HTML_Common HTML_QuickForm HTML_QuickForm_advmultiselect HTML_Table Auth_SASL HTTP Image_Canvas Image_Color Image_Graph Image_GraphViz Mail Mail_Mime Net_SMTP Net_Socket Net_Traceroute Net_Ping Validate XML_RPC


        Mais toujours plein de failed dans : Verifying PHP Pear Component

        Que dois-je faire ?

        Comment


        • #5
          J'ai augmenté le php.ini a 16 M et tout c'est bien déroulé :-P

          Comment


          • #6
            Originally posted by guimev View Post
            J'ai la meme erreur que toi, j'ai également lancé la commande :
            pear install -o -f --alldeps DB DB_DataObject DB_DataObject_FormBuilder MDB2 Date Numbers_Roman Numbers_Words HTML_Common HTML_QuickForm HTML_QuickForm_advmultiselect HTML_Table Auth_SASL HTTP Image_Canvas Image_Color Image_Graph Image_GraphViz Mail Mail_Mime Net_SMTP Net_Socket Net_Traceroute Net_Ping Validate XML_RPC


            Mais toujours plein de failed dans : Verifying PHP Pear Component

            Que dois-je faire ?
            salut

            la version du PEAR est importante certain modules ne s'installent pas si tu n'as pas la version 1.6
            installe la derniere version avec la commande : pear upgrade --force --alldeps PEAR-1.6.1
            c'est ce que j ai du faire
            ensuite tu relance la commande que tu a ecrites lus haut
            en esperant que cela t aide
            Last edited by worm75011; 9 September 2007, 12:46.

            Comment


            • #7
              Souvent le probleme avec l'installation de paquet PEAR vient que la memoire PHP locale vient a manquer, n'hesitez donc a l'augmenter.

              Les warnings ne sont pas genants, c'est juste une indication sur le fait que les paquets demandes ne sont pas encore en version stable.
              Romain Le Merlus
              Centreon Forge
              MERETHIS

              Comment

              Working...
              X