Announcement

Collapse
No announcement yet.

Problème redemarrage via l'interface Centreon

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • vinced
    replied
    onjour !!! voilà moi ça fait maintenant une semaine que j'utilise Centreon et Nagios et toujours des petits soucis:

    La configuration dans Centreon a l'air bonne. Quand j'envoie les fichiers de coinfigurations vers Nagios , il n'y a pas de messages d'erreurs:


    Nagios 2.9
    Copyright © 1999-2007 Ethan Galstad (http://www.nagios.org)
    Last Modified: 04-10-2007
    License: GPL

    Reading configuration data...

    Running pre-flight check on configuration data...

    Checking services...
    Checked 2 services.
    Checking hosts...
    Checked 1 hosts.
    Checking host groups...
    Checked 1 host groups.
    Checking service groups...
    Checked 0 service groups.
    Checking contacts...
    Checked 2 contacts.
    Checking contact groups...
    Checked 1 contact groups.
    Checking service escalations...
    Checked 0 service escalations.
    Checking service dependencies...
    Checked 0 service dependencies.
    Checking host escalations...
    Checked 0 host escalations.
    Checking host dependencies...
    Checked 0 host dependencies.
    Checking commands...
    Checked 47 commands.
    Checking time periods...
    Checked 5 time periods.
    Checking extended host info definitions...
    Checked 1 extended host info definitions.
    Checking extended service info definitions...
    Checked 2 extended service info definitions.
    Checking for circular paths between hosts...
    Checking for circular host and service dependencies...
    Checking global event handlers...
    Checking obsessive compulsive processor commands...
    Checking misc settings...

    Total Warnings: 0
    Total Errors: 0

    Things look okay - No serious problems were detected during the pre-flight check

    cgi.cfg - déplacement OK
    checkcommands.cfg - déplacement OK
    contactgroups.cfg - déplacement OK
    contacts.cfg - déplacement OK
    dependencies.cfg - déplacement OK
    escalations.cfg - déplacement OK
    hostextinfo.cfg - déplacement OK
    hostgroups.cfg - déplacement OK
    hosts.cfg - déplacement OK
    meta_commands.cfg - déplacement OK
    meta_contact.cfg - déplacement OK
    meta_contactgroup.cfg - déplacement OK
    meta_dependencies.cfg - déplacement OK
    meta_escalations.cfg - déplacement OK
    meta_host.cfg - déplacement OK
    meta_hostgroup.cfg - déplacement OK
    meta_services.cfg - déplacement OK
    meta_timeperiod.cfg - déplacement OK
    misccommands.cfg - déplacement OK
    nagios.cfg - déplacement OK
    perfparse.cfg - déplacement OK
    resource.cfg - déplacement OK
    serviceextinfo.cfg - déplacement OK
    servicegroups.cfg - déplacement OK
    services.cfg - déplacement OK
    timeperiods.cfg - déplacement OK

    Running configuration check...done
    Stopping nagios: done.
    Starting nagios: done.


    Jusque là, tout va bien .

    Le problème arrive au moment de redémarrer le service nagios.

    En tapant : #service nagios restart; j'obtiens le message suivant :

    Running configuration check...done
    Stopping nagios: kill: usage: kill [-s sigspec | -n signum | -sigspec] [pid | job]... or kill -l [sigspec]
    done.
    Starting nagios: done.

    wink.gif


    et du coup quand je vais sur l'interface Web de Nagios , impossible d'accéder aux informations envoyées par Centreon

    Quelqu'un aurait il une idée ? Je ne sais pas comment redémarrer le service nagios? On dirait qu'il est impossible de stopper le service nagios car il ne trouve pas le PID associé au service nagios ...


    Quelqu'un peut il m'aider ??

    Leave a comment:


  • lune001
    replied
    Moi c'est le init script /etc/init.d/nagios2 dans "Options Oreon Options Générales Nagios" qui etait en /etc/init.d/nagios, hors sous debian c'est nagios2
    Merci donc !!

    Leave a comment:


  • WAtt
    replied
    Originally posted by Vianney View Post
    pour ma part un apt-get install sudo a reglé le problème...

    merci !
    C'est déjà ca

    Leave a comment:


  • Vianney
    replied
    pour ma part un apt-get install sudo a reglé le problème...

    merci !

    Leave a comment:


  • WAtt
    replied
    Originally posted by elesouef View Post
    Je me suis trompé dans mes tests.

    Via www-data, quand je fais sudo /etc/init.d/nagios2 restart, ca fonctionne. C'est via l'interface web que ca ne fonctionne pas.

    Je vois pas là...
    Salut,

    Tu as quoi dans le champs
    Options -> Options Générales -> Nagios -> Script d'initialisation
    /etc/init.d/nagios2 ou /etc/init.d/nagios ?

    Je regarde si ca peu venir d'ailleur qd meme
    WAtt

    Leave a comment:


  • elesouef
    replied
    Je me suis trompé dans mes tests.

    Via www-data, quand je fais sudo /etc/init.d/nagios2 restart, ca fonctionne. C'est via l'interface web que ca ne fonctionne pas.

    Je vois pas là...

    Leave a comment:


  • tito
    replied
    Originally posted by elesouef View Post
    J'ai exactement le même souci et lorsque je teste le sudoers comme indiqué, il demande une première fois à www-data d'entrer son password. Ce qui est bien evidemment impossible...

    [email protected]:~$ sudo /etc/init.d/nagios reload

    We trust you have received the usual lecture from the local System
    Administrator. It usually boils down to these three things:

    #1) Respect the privacy of others.
    #2) Think before you type.
    #3) With great power comes great responsibility.

    Password:

    Il doit donc y avoir quelque chose à ajouter à la config de sudo pour ne pas avoir ce message.

    Mais quoi ?
    Dans ton fichier sudoers, tu as donné des droits au script /etc/init.d/nagios2.
    Donc m'est avis que /etc/init.d/nagios xxx ne peut pas fonctionner vu qu'il a pas les bons droits.
    Voila j'espere que ça peut t'aider.
    Last edited by tito; 10 September 2007, 18:52.

    Leave a comment:


  • crovax
    replied
    Bonjour.
    Pour ma part j'ai un probleme uniquement au niveau du reload, j'ai les meme lignes qu'au dessous dans mon fichier sudo.
    losrque je fais un : /etc/init.d/nagios2 reload
    j'obtien :
    HTML Code:
    Reloading nagios2 monitoring daemon configuration files: nagios2/etc/init.d/nagi
    * Not running.
     failed!

    Leave a comment:


  • elesouef
    replied
    J'ai ca :

    Defaults env_reset, insults, mail_badpass, mail_no_user, mail_no_host, mail_no_perms, log_host, insults, passwd_tries = 1

    #Add by OREON installation script
    User_Alias OREON= www-data
    ## Nagios Restart
    OREON ALL = NOPASSWD: /etc/init.d/nagios2 restart
    ## Nagios reload
    OREON ALL = NOPASSWD: /etc/init.d/nagios2 reload
    ## Snmptrapd Restart
    OREON ALL = NOPASSWD: /etc/init.d/snmptrapd restart

    Merci de ton aide Watt.

    Leave a comment:


  • WAtt
    replied
    Tu as quoi pour la partie Oreon dans ton fichier sudo ?

    Leave a comment:


  • elesouef
    replied
    J'ai exactement le même souci et lorsque je teste le sudoers comme indiqué, il demande une première fois à www-data d'entrer son password. Ce qui est bien evidemment impossible...

    [email protected]:~$ sudo /etc/init.d/nagios reload

    We trust you have received the usual lecture from the local System
    Administrator. It usually boils down to these three things:

    #1) Respect the privacy of others.
    #2) Think before you type.
    #3) With great power comes great responsibility.

    Password:

    Il doit donc y avoir quelque chose à ajouter à la config de sudo pour ne pas avoir ce message.

    Mais quoi ?

    Leave a comment:


  • Vianney
    replied
    hmm, alors peut etre que sudo n'est pas "installé" ...
    je ne suis pas dessus aujourd'hui, je jette un oeil mardi ...
    mais par defaut je ne dois pas avoir sudo il doit falloir faire un apt-get install sudo ...

    v.

    Leave a comment:


  • WAtt
    replied
    Originally posted by Vianney View Post
    Salut,
    j'ai un soucis lorsque je fais un "reload" ou "restart" apres modification de la conf. (ca ne fonctionne pas)
    ...
    y a t il un problème de droit ? ou de configuration des parametres ?
    nagios dans /etc/init.d est owned par "root" ? ne devrais-je pas affecter les droits à nagios ou à www-data ?
    JAMAIS !!!

    Pour effectuer un restart:reload de nagios, Centreon utilise des commandes via le sudo.

    Avant d'aller plus loin, regarde si le fichier sudo est correct (visudo). Si celui-ci te semble correct, test les commandes.

    Code:
     $> su - www-data
     $www-data> sudo /etc/init.d/nagios reload
    Si ca ne fonctionne pas, reviens nous voir que l'on regarde plus en profondeur. Mais a premiere vu le problème est sur le sudo.

    Bon courage
    WAtt

    Leave a comment:


  • Vianney
    started a topic Problème redemarrage via l'interface Centreon

    Problème redemarrage via l'interface Centreon

    Salut,
    j'ai un soucis lorsque je fais un "reload" ou "restart" apres modification de la conf. (ca ne fonctionne pas)

    les conf sont bien mises à jour, mais le reload ne se fait pas ...
    je peux le faire avec /etc/init.d/nagios restart ou reload via putty sur le serveur lui meme ...

    y a t il un problème de droit ? ou de configuration des parametres ?
    nagios dans /etc/init.d est owned par "root" ? ne devrais-je pas affecter les droits à nagios ou à www-data ?

    merci de vos commentaires ?

    .V
Working...
X