Announcement

Collapse
No announcement yet.

Trouble with post-installation.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Trouble with post-installation.

    Hello,

    I'm using openSuSE 10.3 on a x86 32 bit system (kernel 2.6.22.9-0.4).

    I have installed Centreon 1.4.1. It passed all the steps, but when I pointed out to the URL http://myserver/oreon/ , appears the following:
    "
    query("DELETE FROM session WHERE session_id = '".session_id()."'"); Session:top(); Session:tart(); } if (isset($_SESSION["oreon"])) { // already connected $oreon = & $_SESSION["oreon"]; $pearDB->query("DELETE FROM session WHERE session_id = '".session_id()."'"); Session:top(); Session:tart(); } if (isset($_POST["submit"]) || (isset($_GET["autologin"]) && isset($_GET["p"]) && $_GET["autologin"])) { require_once("DBconnect.php"); isset($_GET["useralias"]) ? $useraliasG = $_GET["useralias"] : $useraliasG = NULL; isset($_POST["useralias"]) ? $useraliasP = $_POST["useralias"] : $useraliasP = NULL; $useraliasG ? $useralias = $useraliasG : $useralias = $useraliasP; isset($_GET["password"]) ? $passwordG = $_GET["password"] : $passwordG = NULL; isset($_POST["password"]) ? $passwordP = $_POST["password"] : $passwordP = NULL; $passwordG ? $password = $passwordG : $password = $passwordP; # BugFix #224 $password = ($password == '' ? time() : $password ); ...
    "

    What I'm doing wrong, please?


    TIA,
    Vinicius.
    Last edited by cviniciusm; 23 October 2007, 01:52. Reason: My question was resolved!

  • #2
    Is PHP and MySQL installed correctly?

    Comment


    • #3
      MySQL is running:
      $ mysqladmin status
      Uptime: 2791 Threads: 1 Questions: 3 Slow queries: 0 Opens: 12 Flush tables: 1 Open tables: 6 Queries per second avg: 0.001

      PHP is not running:
      - I created the file test.php with the contents: <? php phpinfo() ?>
      - It's not showing the php info.

      Using yast2 --> System -> /etc/sysconfig Editor --> Network --> WWW --> Apache2, I set up:
      - APACHE_CONF_INCLUDE_DIRS with /etc/apache2/conf.d/*.conf
      - APACHE_MODULES with actions alias ... php5

      I can't figure out, where is the error?


      Cheers,
      Vinicius.

      Comment


      • #4
        Hello, the php test was wrong, the right one is: <?php phpinfo() ?>

        So, Apache2+MySQL+PHP is working.

        Cheers,
        Vinicius.

        Comment


        • #5
          My Centreon install output.

          Hi,

          I appended the output of ./install.sh.

          Regards,
          Vinicius.
          Attached Files

          Comment


          • #6
            voir le php.ini

            In the file php.ini, verify the value of this parameter :
            short_open_tag = On

            T. ARISTE

            Comment


            • #7
              Cool, now it works!

              Hi,

              I changed the short_open_tag from Off to On.

              Now, the Centreon Setup is working!

              Thanks a lot!

              Best regards,
              Vinicius.
              Attached Files

              Comment

              Working...
              X