Announcement

Collapse
No announcement yet.

Problems with reporting & graph renders?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problems with reporting & graph renders?

    Hello,

    I have a test-lab setup of; Nagios 2.10, Ubuntu 7.10, Centreon 1.4; my initial installation of Oreon went sucessfull. I have managed to import my hosts, services, check commands, etc.. and they show up in Centreon and checks work.

    However I do have some errors, one being that if I try to see a "report" on a host, Centreon will show it as Undetermined 100% of the time. As shown below:

    Click to view image.


    Another error I can't seem to fix, is when trying to render graphs:

    Click to view image

    There is an error above that, however I am not sure I can make any sense out of it. Also in my ods_parsing_log there are error messages:

    Code:
    Can't locate /etc/oreon/ODS/etc.conf.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.8.8 /usr/local/share/perl/5.8.8 usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8 /usr/local/lib/site_perl .) at /etc/oreon/cron/parsing_log.pl line 33
    I also can't seem to find any cron jobs related to oreon or ods, any idea? I tought there has to be some entries there for some processes.

    Any help is thankfull.

    Thanks!

  • #2
    I don't have any "etc.conf.pm" file on my installation.
    But I have a "conf.pm" in installation_directory/ODS/etc/

    So I think the path of the conf.pm file is not good...

    Sorry for my poor english ops:
    Guigui

    > PAS DE SUPPORT VIA MP <

    "Ce n'est qu'en essayant continuellement que l'on finit par réussir. En d'autres termes, plus ça rate et plus on a de chances que ça marche !!" (Shadoks)

    Comment


    • #3
      update oreon 1.4 to centreon 1.4.1..
      Julien Mathis
      Centreon Project Leader
      www.merethis.com |

      Comment


      • #4
        My installation is Oreon 1.4.1, the latest on their download section.

        I am doing a clean install of Ubuntu 7.10, Nagios 2.10, Plugins, and Oreon.

        Hopefully this works.. along with apache2/mysql and all the other libs & pear stuff.

        Comment


        • #5
          I did a fresh install of;

          - Ubuntu 7.10
          - Nagios 2.10 & Plugins
          - Centreon 1.4.1 & Plugins
          - Apache2 / PHP / Perl / Pear
          - MySQL

          I did not import any of my old nagios configs, i wanna start fresh (i don't mind porting over 100 hosts and 300 services for a proper monitoring system).

          I run in the same problems;
          (1) showing Undetermined 100% - which from reading on here you have to let your stuff run for 24hrs for that to disappear and the charts to balance out.

          (2) the hosts does not show up in the drop-down list when trying to generate a host graph (traffic, ping, etc..).

          No idea why this is happening. My screenshots are attached below;

          Nagios CFG:

          Part 1

          Part 2

          Part 3

          Part 4

          Centreon CFG:
          Part 1


          ODS CFG
          Part 1



          And below, are the problems screenshotted; the no-host appearing for graphs when i did collect perfdata for it (as seen on the service graph);

          Part 1

          And here is the undetermined 100% problem;

          View




          I am not sure why this is happening, my directories are as follow:

          - /etc/nagios (NAGIOS)
          - /etc/oreon (CENTRION)


          Any help very aprpeaciated. Thanks!!

          Comment


          • #6
            Originally posted by exoid View Post
            I did a fresh install of;

            - Ubuntu 7.10
            - Nagios 2.10 & Plugins
            - Centreon 1.4.1 & Plugins
            - Apache2 / PHP / Perl / Pear
            - MySQL

            (2) the hosts does not show up in the drop-down list when trying to generate a host graph (traffic, ping, etc..).
            I have the same here. My perfparse is collecting datas, but I can not see possibility to setup charts. I read wiki but I didnt find any helpful infos there. I suspect it is because I have no check_graph* plugins which are present in one of Virtual Alliances Machines I found. I asked for reason of lack them here but no answer so far ...
            Centreon v1.4.2.2 (no graphs)
            Nagios v2.10 + plugins v1.4.10
            ubuntu v7.04 VM vmware

            Comment

            Working...
            X