Announcement

Collapse
No announcement yet.

Probleme de géneration des fichiers

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts
    jsianard
    Junior Member

  • jsianard
    replied
    Peut être bien car j'avoue avoir installé paquet multiverse php-gd2!!
    J'installerais le php-gd de section main lundi et je vous donne de news.

    Big up à tous et bon week.

    joans

    Leave a comment:

  • wistof
    Module Contributor

  • wistof
    replied
    Originally posted by jsianard
    Actuellement je n'ai aucune image sur l'accuel.
    peut-etre pour ça....

    Leave a comment:

  • julio
    Administrator

  • julio
    replied
    php-gd pour la generation des fichiers de conf ?

    Leave a comment:

  • DonKiShoot
    Senior Member

  • DonKiShoot
    replied
    Fonction rechercher du forum :wink:

    PS: regarde du coté de php-gd pi etre :!:

    Leave a comment:

  • jsianard
    Junior Member

  • jsianard
    replied
    Certainement, mais le plus currieux c'est que les paths ds le menu option étaient les bons.
    Actuellement je n'ai aucune image sur l'accuel.
    Si des fois vous avez une petite idée.

    joans

    Leave a comment:

  • julio
    Administrator

  • julio
    replied
    a mon avis fallait configurer dans options->nagioscfg et la y a un petit champ pour les fichiers de confs...

    Leave a comment:

  • little-dino
    Junior Member

  • little-dino
    replied
    Probleme de géneration des fichiers

    Oui merci en tout cas ton astuce semble fonctionner ... je crois savoir pourquoi. en uploadant la fichier nagios.cfg les chemins vers les ressources sont maitenant correctes . C'est à dire si je vais sur

    /usr/local/oreon/nagios_cfg

    J'ai
    cfg_file=/usr/local/nagios/etc/checkcommands.cfg
    cfg_file=/usr/local/nagios/etc/misccommands.cfg
    cfg_file=/usr/local/nagios/etc/contactgroups.cfg
    cfg_file=/usr/local/nagios/etc/contacts.cfg
    cfg_file=/usr/local/nagios/etc/dependencies.cfg
    cfg_file=/usr/local/nagios/etc/escalations.cfg
    cfg_file=/usr/local/nagios/etc/hostgroups.cfg
    cfg_file=/usr/local/nagios/etc/hosts.cfg
    cfg_file=/usr/local/nagios/etc/services.cfg
    cfg_file=/usr/local/nagios/etc/timeperiods.cfg



    au lieu de

    cfg_file=/etc/nagios/etc/checkcommands.cfg
    cfg_file=/etc/nagios/misccommands.cfg
    cfg_file=/etc/nagios/contactgroups.cfg
    cfg_file=/etc/nagios/contacts.cfg
    cfg_file=/etc/nagios/dependencies.cfg
    cfg_file=/etc/nagios/escalations.cfg
    cfg_file=/etc/nagios/hostgroups.cfg
    cfg_file=/etc/nagios/hosts.cfg
    cfg_file=/etc/nagios/services.cfg
    cfg_file=/etc/nagios/timeperiods.cfg



    ce qui est correcte (pour ma config en tout cas)

    J'aimerai quand même comprendre ce qui est arrivé et ce qui fait que le chemin est incorrecte.

    Merci d'avance les gars.

    Leave a comment:

  • jsianard
    Junior Member

  • jsianard
    replied
    Je te propose deux choix le premier celui que j'ai suivi, il s'agit d'uploader le fichier nagios.cfg de ton ancienne conf et puis ensuite tu verras, le comportement n'est plus le meme la géneration ce fait malgré tout ne me demande pas comment mais bon.
    Attention de mode de créations des host et consorts à changer "gros big up aux colèques de la haut car j'ai maintenant ma statusmap.cgi merci à vous" tu verras après la creation de ton host il restera en rouge et oreon et dans nagios, si c'est le cas vérifie dans le fichier resources.cfg si par hasard les paths pointe vers /usr/local/nagios/plugin/ si n'est pas le cas et si c'est vers un genre de usr/lib ou bin alors prend ton courage à trois main et install le paquet nagios-text avec les depends qui vont bien.
    pendant l'install lorsque debconf demande le mdp de l'admin nagios rentre le, mais attention à la question concernant le remplacement du fichier /etc/init.d/nagios repond N ou O.

    Voila bon courage.

    joans

    Leave a comment:

  • little-dino
    Junior Member

  • little-dino
    replied
    Salut !

    J'ai exactement le même problème en voulant faire une m.a.j vers la RC2. Je ne suis plus capable de générer les configuration. J'ai même essayé une réinstallation complète ... rien. :cry: Pour info j'utilise une débian sarge. J'ai vraiment de trouver une solution rapide. S'il le faut revenir à une version antérieure ou mieux sil y a quelque chose à changer un fichier à la main. Merci d'avance !!!

    Leave a comment:

  • julio
    Administrator

  • julio
    replied
    quelle modifs ? tu as fait une upgrade ou alors une simple install ? sinon verifies bien tous les chemins de options->nagios.cfg.

    Leave a comment:

  • jsianard
    Junior Member

  • jsianard
    replied
    Non ca ne marche tjrs pas, c'est peut être trop mais pourriez vous m'indiqué l'endroit où je peut faire le modif avan l'install.

    merci par avance

    joans

    Leave a comment:

  • julio
    Administrator

  • julio
    replied
    Ca marche maintenant alors ?

    t'as du ecraser ecraser ta base de donnée sans faire de migration... c pour ca... g fait une boulette avec la RC2. Les conf sont faites pour les paths des RPM... bientot RC3 avec les paths des tgz

    nous allons faire une options pour que ca verifie que c'est une install en deb ou rpm, ou tgz... car les paths changent tout le temps et du coup faut tout rentrer a la main....

    Leave a comment:

  • jsianard
    Junior Member

  • jsianard
    replied
    Non car je n'ai aucune installation de nagios en native cad paquet debian.
    j'avous que c'est fou d'autan que j'avais une config qui machait au poil.

    joans

    Leave a comment:

  • rom
    Centreoniste

  • rom
    replied
    Alors si tu as bien defini dans configuration->nagios.cfg pour le path des cfg '/usr/local/nagios' et qu'a la generation il te met dans le fichier nagios.cfg '/etc/nagios/*.cfg', il y a clairement un probleme... mais c fou qu'on ne l'ai pas vu...

    Est ce qu'il les genere bien par contre dans le repertoire '/etc/nagios/' ? (ca serait au moins coherent...)

    Leave a comment:

  • jsianard
    Junior Member

  • jsianard
    replied
    Il semble que personne n'est d'idée sur mom pb ?
    joan

    Leave a comment:

Working...
X