Announcement

Collapse
No announcement yet.

Controling nagios3

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Controling nagios3

    Hi.

    My centreon does not restart nagios.

    I have this on /etc/sudoers
    User_Alias CENTREON=www-data
    # Nagios Restart
    CENTREON ALL = NOPASSWD: /etc/init.d/nagios3 restart
    # Nagios reload
    CENTREON ALL = NOPASSWD: /etc/init.d/nagios3 reload
    # Nagios test config
    CENTREON ALL = NOPASSWD: /usr/sbin/nagios3 -v *
    # Nagios test for optim config
    CENTREON ALL = NOPASSWD: /usr/sbin/nagios3 -s *
    # Snmptrapd Restart
    CENTREON ALL = NOPASSWD: /etc/init.d/snmptrapd restart
    # CentStorage Restart
    CENTREON ALL = NOPASSWD: /etc/init.d/centstorage restart
    # CentStorage stop
    CENTREON ALL = NOPASSWD: /etc/init.d/centstorage stop

    And in /var/log/apache2/error.log I have

    We trust you have received the usual lecture from the local System
    Administrator. It usually boils down to these three things:

    #1) Respect the privacy of others.
    #2) Think before you type.
    #3) With great power comes great responsibility.

    [sudo] password for www-data:

    We trust you have received the usual lecture from the local System
    Administrator. It usually boils down to these three things:

    #1) Respect the privacy of others.
    #2) Think before you type.
    #3) With great power comes great responsibility.

    [sudo] password for www-data:




    Hi is asking for a password.

    Any Idea?
    Thanks

  • #2
    Hi .

    Indeed the problem is that centreon is trying to execute /etc/init.d/nagios instead of executing /etc/init.d/nagios3.

    In centreon -> Administration->Option -> nagios the init script is set to "/etc/init.d/nagios3"

    how can I correct this?

    Thanks

    Comment

    Working...
    X