Announcement

Collapse
No announcement yet.

[RESOLU]Petit soucis installation/generation sonde

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [RESOLU]Petit soucis installation/generation sonde

    Rebonjour à tous,
    donc j'ai installé oreon et suite a mes tests de ce matin :roll: je me retrouve avec un soucis lors de l'installation du install.sh (install_nagios_by_oreon), lors de l'installation de nagios 1.2, il me genere une erreur
    ./install.sh: line 298: [: =: unary operator expected
    Enable to find the Apache version. Please check your Apache version.
    OREON need Apache v2. Go to www.apache.org for more information
    Apache2 est bien installé et tourne........Comprend pô

    Je passe cette erreur et j'arrive a me connceter/paramétrer le tout mais quand je veux generer les sondes il me genere des erreurs:
    Warning: fopen(/usr/local/nagios/libexec/oreon.conf): failed to open stream: Permission denied in /usr/local/oreon/include/generatefile/oreon_pm.php on line 122

    Warning: fwrite(): supplied argument is not a valid stream resource in /usr/local/oreon/include/generatefile/oreon_pm.php on line 145

    Warning: fwrite(): supplied argument is not a valid stream resource in /usr/local/oreon/include/generatefile/oreon_pm.php on line 152


    Warning: fwrite(): supplied argument is not a valid stream resource in /usr/local/oreon/include/generatefile/oreon_pm.php on line 152

    Warning: fwrite(): supplied argument is not a valid stream resource in /usr/local/oreon/include/generatefile/oreon_pm.php on line 152
    ..............................
    J'ai verifié les droits qui sont ok....Donc je ne peux plus avancer, je cherche mais ...Si quelqu'un voit ou ca bloque :lol:
    Je suis preneur de son aide....
    En remerciant par avance.
    ++
    ------------------------------
    Cordialement
    BooBz

    Debian 2.6.18-5-xen-686 / Nagios 1.2/ Oreon 1.2.2
    ( Prochainement virtualisé et updaté :-) )

  • #2
    Pourrais-tu donner davantage d'informations, notamment la distribution utilisée, l'origine de nagios (recompilation maison ou paquet debian/rpm) ?
    Raphaël 'SurcouF' Bordet
    Je ne teste pas mes plugins en root, tu ne testes pas tes plugins en root...
    Dons Paypal

    Comment


    • #3
      Rebonjour,
      je suis sous debian 2.6.8.
      Je pensais que Nagios avait été installé via le script install_nagios_by_oreon
      Apparement un dpkg -l nagios* ne me donne aucune reponse.....
      Serait ce le problème...Je teste ca et tiens au courant...
      A++
      ------------------------------
      Cordialement
      BooBz

      Debian 2.6.18-5-xen-686 / Nagios 1.2/ Oreon 1.2.2
      ( Prochainement virtualisé et updaté :-) )

      Comment


      • #4
        Originally posted by boobz
        Rebonjour,
        je suis sous debian 2.6.8.
        Je pensais que Nagios avait été installé via le script install_nagios_by_oreon
        Apparement un dpkg -l nagios* ne me donne aucune reponse.....
        Serait ce le problème...Je teste ca et tiens au courant...
        Quelle version d'Oreon essaies-tu d'installer ? Visiblement pas une 1.2.x car cette fonction a disparu de l'archive. Sinon, je te conseille d'installer nagios via les paquets de debian, les versions actuelles d'oreon peuvent facilement s'y adapter, en attendant mieux.
        Raphaël 'SurcouF' Bordet
        Je ne teste pas mes plugins en root, tu ne testes pas tes plugins en root...
        Dons Paypal

        Comment


        • #5
          Alors je suis pas à pas la documentation donc je pars sur install_nagios_by_oreon-v03 '(c'est quand je lance l'install.sh, ca bloque à la fin apres l'installation des plugin nagios :
          Configure Apache server ...
          ./install.sh: line 298: [: =: unary operator expected
          Enable to find the Apache version. Please check your Apache version.
          OREON need Apache v2. Go to www.apache.org for more information
          )
          J'ai testé sur 2 machines différentes, même soucis, même erreur, je dois passer a coté de quelque chose de tellement gros que je le vois pas ;-)
          ------------------------------
          Cordialement
          BooBz

          Debian 2.6.18-5-xen-686 / Nagios 1.2/ Oreon 1.2.2
          ( Prochainement virtualisé et updaté :-) )

          Comment


          • #6
            C'est ok l'installation s'est bien deroulée....La generation des sondes aussi....Me reste donc a tester si mon serveur recupère bien les informations et si les graph fonctionne....
            C'est que je vais y passer du temps :roll:
            Merci a ceux qui m'ont aiguillé...
            pour resoudre mon soucis, apt-get remove --purge apache
            Mon serveur ne tourne QUE sous apache2.....
            ++
            ------------------------------
            Cordialement
            BooBz

            Debian 2.6.18-5-xen-686 / Nagios 1.2/ Oreon 1.2.2
            ( Prochainement virtualisé et updaté :-) )

            Comment


            • #7
              Originally posted by boobz
              C'est ok l'installation s'est bien deroulée....La generation des sondes aussi....Me reste donc a tester si mon serveur recupère bien les informations et si les graph fonctionne....
              C'est que je vais y passer du temps :roll:
              Merci a ceux qui m'ont aiguillé...
              pour resoudre mon soucis, apt-get remove --purge apache
              Mon serveur ne tourne QUE sous apache2.....
              Je persiste à penser que tu utilises une ancienne version.
              Oreon ne dépend pas spécialement d'Apache2, le script que tu utilises doit être bogué.
              Raphaël 'SurcouF' Bordet
              Je ne teste pas mes plugins en root, tu ne testes pas tes plugins en root...
              Dons Paypal

              Comment

              Working...
              X