Announcement

Collapse
No announcement yet.

[REGLE] install sur une Debian - Stable

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Abyss
    replied
    Je suis actuellement en stage et j'ai beaucoup de temps pour nagios, pourrai je vous aider dans la phase de test ?
    Ca me rendrai grandement service, et puis un testeur de plus ca peu toujours servir :wink:

    il faut dire que je suis en train de rediger un rapport sur comment installer la version 0.2 et s'en servir, il sera donc obsolete a la sortie de votre nouvelle version (que j'attend avec grande impacience ), j'aimerai donc bien me mettre a bosser dessus tout de suite

    Merci

    Leave a comment:


  • kikidonc
    replied
    On termine la phase de tests actuellement.
    On va dire fin janvier

    Leave a comment:


  • Abyss
    replied
    Et quand ce messie verra il le jour ?

    Leave a comment:


  • kikidonc
    replied
    des problemes sont connus au niveau de l'install sur debian.
    La nouvelle version corrige normalement ces bugs (tests effectue sur plusieurs environnements debian).
    Elle sera dispo avec la futur version d'OREON (qui va beaucoup changer ! )

    Leave a comment:


  • Abyss
    started a topic [REGLE] install sur une Debian - Stable

    [REGLE] install sur une Debian - Stable

    Voila j'utilise une Debian stable version
    versions :
    Apache/2.0.52
    mysqld Ver 4.0.23
    Php4
    lors de l'installation d'Oreon, il survient plusieurs problemes, notament concernant la config de apache V2, mais l'utilisation de apache-utils solutionne (faussement) le probleme

    par contre je recontre un autre probleme qui me donne beaucoup plus de mal, quelqun a une idée / solution ?
    (je suis bien logué en root)

    Probleme :
    (tout le reste se passe sans soucis)
    Do you want to start nagios server ? [yes/no] yes
    #debut de l'erreur
    su: invalid option -- l
    Usage: su [OPTS] [-] [username [ARGS]]
    - make this a login shell
    -c, --command=<command>
    pass command to the invoked shell using its -c
    option
    -m, -p, --preserve-environment
    do not reset environment variables, and keep the
    same shell
    -s, --shell=<shell>
    use shell instead of the default in /etc/passwd

    Do you want to install OREON web interface? [yes/no] yes
    install oreon ...
    chown: `:': cannot omit both user and group
    chown: `:': cannot omit both user and group

    #fin de l'erreur
    sudo is already configurate
    Start Mysql server ...
    Stopping MySQL database server: mysqld.
    Starting MySQL database server: mysqld.

    (j'ai essayé de demarrer nagios "a la main" mais il me donne la meme erreur)

    su -l : cette option n'est pas prise en charge par Debian.
    Cette option spécifie que le shell en cours est utilisé comme session de travail d'après ce que j'en ai compris.
    solution :
    vi /etc/init.d/nagios restart
    remplacer "su -l" par "su -"

    seule la page d'apache est dispo sur le site, je n'arrive ni a aller sur http://<mon serveur>/nagios/ ni sur http://<mon serveur>/oreon
    [edit : apres de nombeux bidouillages, il apparait que le install.sh ne modifie pas le bon fichier de config de apache, apres correction, j'arrive a atteindre http://<mon serveur>/nagios/ mais toujours pas /oreon, /oreon me propose de telecharger un fichier "application/x-httpd-php" (dixit firefox) en fait il fait charger le fichier "index.php" qu'il renomme en "oreon"
    qui contient :
    <?
    /**
    Oreon is developped with Apache Licence 2.0 :
    http://www.apache.org/licenses/LICENSE-2.0.txt
    Developped by : Jean Baptiste Gouret - Julien Mathis - Mathieu Mettre - Romain Le Merlus - Yohann Lecarpentier
    Under control of Flavien Astraud, Jerome Landrieu for Epitech.
    Oreon is developped in partnership with Linagora company.

    For information : [email protected]
    */
    include_once ("./oreon.conf.php");
    if (!strcmp($conf_oreon["password"], "") && !strcmp($conf_oreon["url"], ""))
    header("Location: ./install/setup.php");
    include_once ("$classdir/Session.class.php");
    include_once ("$classdir/OreonDatabase.class.php");
    include_once ("$classdir/User.class.php");
    include_once ("$classdir/Oreon.class.php");


    Session:tart();

    etc......
    cela viendrai d'une mauvaise config de apache ? php ?

    Solution : installer le paquet
    php4-cgi
    rajouter dans le httpd.conf (ou apache2.conf)
    LoadModule actions_module /usr/lib/apache2/modules/mod_actions.so
    Action application/x-httpd-php /cgi-bin/php4

    apt-get install php4-mysql


    probleme suivant !

    nom d'util : admin
    mdp : a la config

    apparement pour la suite ca se passe dans le fofo interface

    voila voila merci
    (je vais rediger ca au propre pour les futurs utilisateurs de debian woody)
Working...
X