Announcement

Collapse
No announcement yet.

Migration to new installation to upgrade both centreon and the operating system

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Migration to new installation to upgrade both centreon and the operating system

    Dear all,

    I have been looking for instruction to upgrade our current distributed installation and have followed many instructions on this forum with no luck.
    So I decided to create and account and post in order to get assistance for more experienced users on this forum.

    The current setup is as follows
    One central poller (hosting as well the db and web) and 2 satellite poller.
    On the central server, the following has been installed.

    # yum list installed | grep centre
    centreon.noarch 2.5.2-3.el5.centos installed
    centreon-base-config-centreon-engine.noarch 2.5.2-3.el5.centos installed
    centreon-broker.x86_64 2.6.3-5.el5.centos installed
    centreon-broker-cbd.x86_64 2.6.3-5.el5.centos installed
    centreon-broker-cbmod.x86_64 2.6.3-5.el5.centos installed
    centreon-broker-core.x86_64 2.6.3-5.el5.centos installed
    centreon-broker-storage.x86_64 2.6.3-5.el5.centos installed
    centreon-clapi.noarch 1.6.1-1.el5.centos installed
    centreon-clib.x86_64 1.4.0-1.el5.centos installed
    centreon-common.noarch 2.5.2-3.el5.centos installed
    centreon-connector.x86_64 1.1.0-1.el5.centos installed
    centreon-connector-perl.x86_64 1.1.0-1.el5.centos installed
    centreon-connector-ssh.x86_64 1.1.0-1.el5.centos installed
    centreon-engine.x86_64 1.4.6-2.el5.centos installed
    centreon-engine-daemon.x86_64 1.4.6-2.el5.centos installed
    centreon-engine-extcommands.x86_64 1.4.6-2.el5.centos installed
    centreon-perl-libs.noarch 2.5.2-3.el5.centos installed
    centreon-plugin-meta.noarch 2.5.2-3.el5.centos installed
    centreon-plugins.noarch 2.5.2-3.el5.centos installed
    centreon-trap.noarch 2.5.2-3.el5.centos installed
    centreon-web.noarch 2.5.2-3.el5.centos installed
    centreon-widget-graph-monitoring.noarch 1.1.0-3 installed
    centreon-widget-host-monitoring.noarch 1.1.2-1 installed
    centreon-widget-hostgroup-monitoring.noarch 1.1.1-2 installed
    centreon-widget-service-monitoring.noarch 1.1.2-1 installed
    centreon-widget-servicegroup-monitoring.noarch

    # cat /etc/*release*
    cat: /etc/lsb-release.d: Is a directory
    CentOS release 5.10 (Final)
    #

    On each satellite poller, the following has been installed

    # yum list installed | grep centre
    centreon-broker.x86_64 2.6.3-5.el6 @ces-standard-stable
    centreon-broker-cbd.x86_64
    centreon-broker-cbmod.x86_64
    centreon-broker-core.x86_64
    centreon-broker-storage.x86_64
    centreon-clib.x86_64 1.4.0-1.el6 @ces-standard-stable
    centreon-common.noarch 2.5.2-3.el6 @ces-standard-stable-noarch
    centreon-connector.x86_64
    centreon-connector-perl.x86_64
    centreon-connector-ssh.x86_64
    centreon-engine.x86_64 1.4.6-2.el6 @ces-standard-stable
    centreon-engine-daemon.x86_64
    centreon-engine-extcommands.x86_64
    centreon-perl-libs.noarch
    centreon-plugins.noarch 2.5.2-3.el6 @ces-standard-stable-noarch
    centreon-poller-centreon-engine.noarch
    centreon-trap.noarch 2.5.2-3.el6 @ces-standard-stable-noarch

    # cat /etc/*release*
    CentOS release 6.5 (Final)
    LSB_VERSION=base-4.0-amd64:base-4.0-noarch:core-4.0-amd64:core-4.0-noarch:graphics-4.0-amd64:graphics-4.0-noarchrinting-4.0-amd64rinting-4.0-noarch
    cat: /etc/lsb-release.d: Is a directory
    CentOS release 6.5 (Final)
    CentOS release 6.5 (Final)
    cpe:/o:centos:linux:6:GA

    Since I want to as well upgrade the centos version for the central poller, I have downloaded and install central poller (on a vm) with the latest availabe iso (centreon-3.4.1-x86_64.iso)
    Then i did a yum update to have the latest version (2.8.4)

    And now since we have many host services I'd like to migrate the current setup/config form the old server to the new installation but it is not successful on every attempt.
    First I tried using this article
    https://forum.centreon.com/forum/cen...re-for-ces-3-0
    In the end when I check I cannot open different pages (for instance i cannot open any of the host to edit, but i see on the main screen, top right, that the number of host and services matches the one on the old server) and the version number on the main login screen is still showing the previous version.

    Then i tried the CLAPI method, I could export but could not import.
    On the new server I did
    centreon -u admin -p mypass -i /root/clapi-export.txt
    I tried with the suggested order,
    so first start with timeperiod
    ./centreon -u admin -p mypass -o TIMEPERIOD -a show > /tmp/TIMEPERIOD.txt
    Then import on the new server (centreon -u admin -p mypass -i /root/TIMEPERIOD.txt)
    Still fail i get
    Object id not found in Centreon API.
    Object 1 not found in Centreon API.
    Object 2 not found in Centreon API.
    Object 3 not found in Centreon API.
    Object 4 not found in Centreon API.
    Object 5 not found in Centreon API.

    This is how the file looks
    # cat /root/TIMEPERIOD.txt
    id;name;alias;sunday;monday;tuesday;wednesday;thur sday;friday;saturday
    1;24x7;24_Hours_A_Day,_7_Days_A_Week;00:00-24:00;00:00-24:00;00:00-24:00;00:00-24:00;00:00-24:00;00:00-24:00;00:00-24:00
    2;none;No Time Is A Good Time;;;;;;;
    3;nonworkhours;Non-Work Hours;00:00-24:00;00:00-09:00,17:00-24:00;00:00-09:00,17:00-24:00;00:00-09:00,17:00-24:00;00:00-09:00,17:00-24:00;00:00-09:00,17:00-24:00;00:00-24:00
    4;workhours;Work hours;;09:00-17:00;09:00-17:00;09:00-17:00;09:00-17:00;09:00-17:00;
    5;24x7-Enersoft;24_Hours_A_Day,_7_Days_A_Week-Enersoft;02:30-24:00;02:30-24:00;02:30-24:00;02:30-24:00;02:30-24:00;02:30-24:00;02:30-24:00

    Any hint or suggestions will be greatly appreciated
    And sorry for the long message, i wanted to give as much information as possible but let me know if you require anything else.

    thank you
Working...
X