Announcement

Collapse
No announcement yet.

Update to Centreon 3.4 - Error "Update-CSTG-2.7.10_to_2.8.0-beta1.sql..."

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Update to Centreon 3.4 - Error "Update-CSTG-2.7.10_to_2.8.0-beta1.sql..."

    Hello everyone,

    I try to update my centreon using this documentation : https://documentation-fr.centreon.co..._packages.html

    When I get to the web installation, during the 4th phase I face the following error : "Update-CSTG-2.7.10_to_2.8.0-beta1.sql Line 2: DB Error: already exists"

    centreon_update_error.jpg

    Currently my configuration is :

    centreon => 2.7.10-3
    broker => 2.11.8-2
    engine => 1.5.3-1

    I can't figure out how to solve this issue, is anyone already face the problem and knows a solution ?

    Thanks for your help.

    AM.




  • #2
    Hi, i have the same problem.

    I am trying to update to the last version of centreon, from 2.7.8 to 2.8.8. with yum

    I have followed the same documentation as Apsha, and i have the same error.

    I have made some investigation on the database, it like the two .sql file of the update 2.7.10 to 2.8.0-beta1 was already executed.

    For testing when i have this error i have commented the two SQL file. After doing this i have hit the refresh button.
    And now the 2.7.10 to 2.8.0-beta1 was executing in infinite loop, it’s like the update is not tagged ok and the upgrade loop on this update.

    When a have made a test run on a clone couple of weeks ago (2.7.8 to 2.8.6) everythings works fine.

    Thanks for Help
    Last edited by Jayce; 1 week ago.

    Comment


    • #3
      Originally posted by Jayce View Post
      for testing i have commented the Two sql file and do a refresh
      the 2.7.10 to 2.8.0-beta1 runn in boucle.
      Hi,

      I did that too and had the same execution loop...

      Are you running the same version of modules than me ?

      I forget to mention that I am on CentOS 6.9.



      Comment


      • #4
        Hello,

        I do not use LDAP with centreon and it is not really the subject here... You should open a new post for that.

        However I tried your downgrade command prior to the 2.8.8 upgrade, still no success for me...

        Starting with my initial configuration, here is what I recently tried :

        1. Downgrade to 2.7.8 > Upgrade to 2.8.8 = Same error

        2. Downgrade to 2.7.0 > Upgrade to 2.8.8 = Same error

        3. Downgrade to 2.7.0 > Upgrade to 2.7.8 > Upgrade to 2.8.8 = Same error

        Thanks for your help

        Comment


        • #5
          Apsha : Thanks for your comments...
          The comments about the LDAP issues was offtopic.
          I moved it to a new thread.

          Please let me know if there is anything.

          Comment


          • #6
            I ran into exactly the same issue. It seems clear to me (and I think to everyone) that there is something wrong with the update scrip for the DB, this thread has been open for 3 days so I am hoping that the Centreon guys will notice it and give us an idea of how to fix this or some work around

            Comment


            • #7
              So the good guy of Centreon are already aware of this issue and have a work around and according to the thread the fix will be included in 2.8.9
              would suggest to the Centreon guys to also post these types of solutions in the forums.

              https://github.com/centreon/centreon/issues/5220

              Comment


              • #8
                Thank you for the link !

                I'll try and post my result here.

                Comment


                • #9
                  Hi,

                  found fix and works for me :

                  https://github.com/centreon/centreon/issues/5220

                  Go to : cd /usr/share/centreon/www/install/sql/centstorage/

                  Edit this file : Update-CSTG-2.7.10_to_2.8.0-beta1.sql

                  Comment line 2 and line 5 like that: add "--" before

                  HTML Code:
                  -- OPTIMIZE Monitoring
                  -- ALTER TABLE services ADD INDEX last_hard_state_change (last_hard_state_change);
                  -- Add Timezone in hosts TABLE
                  -- ALTER TABLE `hosts` ADD COLUMN `timezone` varchar(64) DEFAULT NULL AFTER `statusmap_image`;


                  Generate configuration and restart service centreon after upgrade.






                  Attached Files

                  Comment

                  Working...
                  X