Announcement

Collapse

GDPR - Your personal data is important

We value your personal data and ensure you that we will continue to secure the storage of the information you share with us regarding your use of this forum (email address, IP address, location, etc.) and only use them upon consent, and towards the purpose it’s intended for. Email us at community@centreon.com to request the update or deletion of your data.

If you wish to make sure you get all our latest tutorials, customer success stories, product updates and many great news, subscribe now to our monthly newsletter.

-------------------------------------------------------------------

Nous accordons beaucoup d’importance au traitement de vos données personnelles. Soyez assurés que les informations collectées dans le cadre de votre utilisation de ce forum (adresse email, IP de connexion, localisation, etc.) sont stockées de manière sécurisée et qu’elles ne sont utilisées que dans le cadre pour lequel elles sont été collectées. Pour toute demande de modification ou suppression de vos informations, écrivez-nous à community@centreon.com.

Si vous souhaitez recevoir tous nos tutoriels, retours d’expériences, nouveautés produit et bien d’autres actualités, (ré)abonnez-vous sans attendre à notre newsletter mensuelle !
See more
See less

centreon-engine - (No output returned from plugin)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • centreon-engine - (No output returned from plugin)

    I'm getting no output from a couple of services - but everything looks correct. I've just migrated from nagios+centweb to the CES / centreon-vm.

    The command shown in the webfrontend looks like:

    without shell enabled:
    /usr/lib/nagios/plugins/check_snmp_environment.pl -H 10.0.0.1 -C community -T cisco

    with shell enabled:
    /bin/sh -c '/usr/lib/nagios/plugins/check_snmp_environment.pl -H 10.0.0.1 -C community -T cisco'

    both returns:
    1 ps OK, 1 temp OK : OK

    I've run that command with the users: centreon, root and centreon-engine. It works with all of them like:
    # su centreon-engine
    bash-4.1$ /usr/lib/nagios/plugins/check_snmp_environment.pl -H 10.0.0.21 -C DRM-3X515-RO -T cisco
    1 ps OK, 1 temp OK : OK

    the sql select for the command executed returns the same commands as above:
    SQL query: SELECT h.name, s.command_line FROM services AS s,hosts AS h WHERE s.host_id = h.host_id AND h.name LIKE 'host%' LIMIT 0, 30 ;
    Host /usr/lib/nagios/plugins/check_snmp_environment.pl -H 10.0.0.1 -C community -T cisco
    host /bin/sh -c '/usr/lib/nagios/plugins/check_snmp_environment.pl -H 10.0.0.1 -C community -T cisco'
    I've tried without and with perl connector - but in the webfrontend I still get no response.

    Does someone has an idea whats the cause here ?




    ## edit:

    is it possible that centreon-engine reacts bad to the
    # nagios: -epn
    entry?

    I've removed this and now its working, but I dont expect this could be the issue?
    using this script: https://github.com/ovido/nagios-plug...environment.pl






    Last edited by Burnout; 13th April 2017, 11:07.
Working...
X