Announcement

Collapse

New forum rules

The forum get new posts rules.

A new user will be moderate for new post. After five valid posts, the user will be to have right to post without moderation.

If you have some issue to post or to connect, contact us.
See more
See less

Graph 6 months instead of 1 year

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Graph 6 months instead of 1 year

    Hi,

    Centreon-web : 2.8.15
    Centreon-engin : 1.7.2
    Centreon-broker : 3.0.7

    I need you help because I don't know why my retention is 6 months for all my graphs. The history of all my gaph is 6 months

    See below my configuration :



    The retention is configured to 365 days.

    ---------------

    I check the data in MariaDB (centreon_storage D :

    I execute this SQL command in order to check the "ctime" of my datas. Ex for metric ID 3301

    select * from data_bin where id_metric=3301 INTO OUTFILE '/tmp/data_bin_3301.txt'

    The ctime on the first line is : 1477692521 (2016/10/29)

    So I can conclude that I have 1 year of data into my database.

    ---------------

    Then I tried to rebuid my graphs :

    1. Delete files in /var/lib/centreon/metrics/3301.rrd and /var/lib/centreon/status/26704.rrd
    2. Graphs are now all gone
    3. Select "Rebuild RRD database" in Admin->Data for the host
    4. RRD files are recreated

    But still the same issue, the history of the graph is again 6 months.

    Do you have any idea to fix this ?

    Thanks you so much for you help

  • #2
    Hello,

    You can go in Administration > Parameters.
    There is a "Performance Management" section on the left.
    Under, select the "Options" link.

    You should see a line that is called "RRDTool database size".

    Default value is 180 days (6 month).
    If it's the value you have, try to set it to your desired value.

    Comment


    • #3
      Hi Nicolas,

      Thanks but I already try to change this value :


      https://www.hostingpics.net/viewer.p...ntreondata.png

      I don't know why this value is not applied ...

      Comment


      • #4
        Hello,
        I have the same issue with a 2.8.24 version.
        All my graphs have a 6 month data, and on database I have more than one year (450 days like I configure on the BO)

        Did you have found a workaround or a patch ?
        Regards

        Comment


        • #5
          Hello all,
          we also have the same issue here, with a 2.7.13.
          It looks like I have the datas in the table, but the graphs does not show all of the datas, only the ones younger than 6 months (180 days)...
          I definitely don't understand where this 180 value comes from...
          Any help?

          Comment

          Working...
          X